Closed Bug 212484 Opened 18 years ago Closed 18 years ago

Session history doesn't distinguish between case insensitive URL's

Categories

(Core :: DOM: Navigation, defect)

x86
NetBSD
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 99091

People

(Reporter: iizogii, Assigned: radha)

References

()

Details

User-Agent:       Mozilla/5.0 (X11; U; NetBSD i386; en-US; rv:1.3.1) Gecko/20030527
Build Identifier: Mozilla/5.0 (X11; U; NetBSD i386; en-US; rv:1.3.1) Gecko/20030527

When following a link from one page to a second page, where the second page has
the same url except for a different case, the mozilla session history does not
distinguish between the two pages.  eg. The session history seems to consider
"http://www.somewhere.com/page.html" equivalent to
"http://www.somewhere.com/PaGe.html" -- even if the web server considers them
different and returns different pages.

This means, for example, that the back button will ignore the original page,
causing to either jump back to the page before the original page, or be disabled.


Reproducible: Always

Steps to Reproduce:
1. Open http://www.mcs.vuw.ac.nz/~jester/misc/moztest/Cap_Back_Test.html in a
new window or tab, so that there's no history for the window.
2. Click the link to visit the other page where the URL is in all lower case.

Actual Results:  
The back functionality is not available to return to the original page.


Expected Results:  
Mozilla should have distinguished between the two pages, so that the original
page could be returned to by pressing the back button, for example.

Also replicated in Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4)
Gecko/20030704 Debian/1.4-1.

*** This bug has been marked as a duplicate of 99091 ***
Status: UNCONFIRMED → RESOLVED
Closed: 18 years ago
Resolution: --- → DUPLICATE
Component: History: Session → Document Navigation
QA Contact: chrispetersen → docshell
You need to log in before you can comment on or make changes to this bug.