If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Keyword parameter expansion doesn't escape &

RESOLVED DUPLICATE of bug 123006

Status

SeaMonkey
Bookmarks & History
RESOLVED DUPLICATE of bug 123006
14 years ago
13 years ago

People

(Reporter: Mikhail Zabaluev, Assigned: Pierre Chanial)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030624
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030624

I have a bookmark to search on a site with the keyword 'e2' and the following
parameterized location:
http://www.everything2.com/index.pl?node=%s

When I enter "e2 Heckler & Koch" in the location bar, the & character doesn't
get its proper percent-escape in the resulting URL:
http://www.everything2.com/index.pl?node=Heckler%20&%20Koch

As the result, "%20Koch" is treated as a separate query parameter.

P.S. Spaces are used to be escaped by '+' in the URL form data encoding,
although '%20' seems to be OK as well.

Reproducible: Always

Steps to Reproduce:
1. Create a bookmark with a parameterized URL and a keyword.
2. Enter the keyword followed by a parameter string including '&'. 

Actual Results:  
Incorrect encoding of the resulting URL.

Expected Results:  
The '&' character should have been escaped as '%26'.

Comment 1

14 years ago

*** This bug has been marked as a duplicate of 123006 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.