Self Closing Script Tag Not Parsing Properly

RESOLVED DUPLICATE of bug 203398

Status

RESOLVED DUPLICATE of bug 203398
16 years ago
14 years ago

People

(Reporter: jim.bruin, Unassigned)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030529
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030529

If a script tag is self closing, and there is a normal set of script tags (one
to open, one to close) later in the document, html between the script tags is
not displayed.


Reproducible: Always

Steps to Reproduce:
1.  Copy and paste the following to a file:

<html>
<body>
	<script language="JavaScript" src="narf.scr"/>
	<h1>Ha Ha NARF!  This is a test!</h1>
	<script language="JavaScript">
		alert("TROZ");
	</script>
</body>
</html>

(If you want, you can remove the 'src' attribute from the first script tag.)

2.  Load the page in a browser.


Actual Results:  
The "<h1>Ha Ha NARF!  This is a test!</h1>" is not rendered.

Expected Results:  
It should have rendered "<h1>Ha Ha NARF!  This is a test!</h1>"

Comment 1

16 years ago

*** This bug has been marked as a duplicate of 203398 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.