[CTL-de] na + halant + ta + halant + ra + aa matra + bindu is not displayed properly

RESOLVED DUPLICATE of bug 211921

Status

()

RESOLVED DUPLICATE of bug 211921
16 years ago
10 years ago

People

(Reporter: alok.kumar, Assigned: prabhat.hegde)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(4 attachments, 1 obsolete attachment)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030712
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030712

The sequence न्त्रां is not displayed
properly. In fact न्त्रा is displayed
properly but as soon as you add ं to it the display goes for a toss.

Reproducible: Always

Steps to Reproduce:
Steps to Reproduce:
1. Make sure you have a ctl enabled build and the sun-unicode-india encoded
fonts, as mentioned in http://www.arbornet.org/~marcow/howto.html
2. Load the url mentioned above.
3. Notice how the line containing Top: World: Hindi:devanagari word1:devanagari
word 2 is displayed
4. View the same using mozilla on win2k/winxp with the indic language pack
installed and otf fonts installed (see http://geocities.com/alkuma/seehindi.html
for instructions)
5. Compare the difference.


Actual Results:  
The problem is with devanagari word 2, the second cluster of the three in the
word are not displayed.

Expected Results:  
View the same in win2k/xp with indic pack installed and an ot font that contains
conjuncts.

I have filed http://bugzilla.mozilla.org/show_bug.cgi?id=212583 separately, if
they have the same root cause, one of them can be marked a duplicate.
(Reporter)

Comment 1

16 years ago
Created attachment 127814 [details]
This is the test case containing the same character as in the sample url
(Reporter)

Comment 2

16 years ago
Created attachment 127816 [details]
Screen shot using the ctl enabled build

The title bar(rendered by pango on gnome 2) displayed the last word correctly
but the same word is not displayed properly on the html page.
(Reporter)

Comment 3

16 years ago
Created attachment 127817 [details]
The word and the letter

The first line contains the whole 3 letter word and the second one contains
only the middle letter of the 3 letter word.
Attachment #127814 - Attachment is obsolete: true
(Reporter)

Comment 4

16 years ago
Created attachment 127818 [details]
correct display of word and letter

renderd by gedit which uses pango on gnome 2
(Reporter)

Comment 5

16 years ago
Created attachment 127819 [details]
Incorrect display of word and letter

Using ctl enabled mozilla build, the word is displayed with the middle letter
missing and the middle letter on its own is displayed as boxes.
(Assignee)

Comment 6

16 years ago
On first look this appears to be a bug in the shaper. Taking.
(confirming, since this has been accepted by a developer)
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Updated

16 years ago
Depends on: 211921
(Reporter)

Comment 8

16 years ago
Making this a duplicate of bug 211921 is more appropriate as this observation is
a subset.

*** This bug has been marked as a duplicate of 211921 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
No longer depends on: 211921
Resolution: --- → DUPLICATE

Updated

10 years ago
Component: Layout: CTL → Layout: Text
QA Contact: arthit → layout.fonts-and-text
You need to log in before you can comment on or make changes to this bug.