Unicode Hebrew with vowels and cantillation marks displayed with dotted circles

RESOLVED DUPLICATE of bug 60546

Status

()

defect
RESOLVED DUPLICATE of bug 60546
16 years ago
11 years ago

People

(Reporter: peter, Assigned: mkaply)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030624
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030624

This page, the start of the Hebrew Bible, is certainly a challenge for Mozilla.
I am trying to view it with the font Ezra SIL (from www.sil.org) which is
designed for displaying the Hebrew Bible in Unicode. What I see is a dotted
circle with every vowel and cantillation mark. The rendering system is
completely failing to render the vowels and cantillation marks as combining marks.

The page does display correctly in IE6, with a very recent version of Uniscribe.

The site owners recognise the problem with Mozilla, see
http://www.mechon-mamre.org/ (in English). The version of the text without
cantillation marks but with vowels, http://www.mechon-mamre.org/i/t/t0101.htm,
displays better but not perfectly - it is CP1255 encoded.


Reproducible: Always

Steps to Reproduce:
(Reporter)

Comment 1

16 years ago
This may be partly a dupe of bug 60546. It is partly fixed by copying the
version of Uniscribe to be released with Office 11 into the same directory as
mozilla.exe; the dotted circles disappear, and the text is readable though it
still has diacritic placement problems which look like bug 60546.
Mechon Mamre seem to have changed their style sheets recently:
http://www.mechon-mamre.org/c/ct/c.css now uses
 font-family: "Ezra SIL SR", "Ezra SIL", code2000, Cardo, "Guttman
Vilna-Normal",              
              Galaxie,"Arial Unicode MS"
and I see http://www.mechon-mamre.org/c/ct/c0101.htm almost perfectly. (To
display it absolutely perfectly, we would need better OpenType support, which
there are other bugs about.)

http://www.mechon-mamre.org/i/t/t0101.htm still uses David, and still displays
badly unless I override the fonts.

*** This bug has been marked as a duplicate of 60546 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 3

16 years ago
Thank you, Simon. I still see many of the points displaced to the left, but that
may be something to do with my rather untypical setup. I have been in e-mail
conversation with the Mechon Mamre webmaster about related Hebrew rendering
issues, which may have prompted the change, and there has been extensive
discussion on the public Unicode list about the issues, which may be of interest
to you.

Updated

11 years ago
Component: Layout: BiDi Hebrew & Arabic → Layout: Text
QA Contact: zach → layout.fonts-and-text
You need to log in before you can comment on or make changes to this bug.