Build failure due missing "nsToolkitCompsCID.h"

VERIFIED DUPLICATE of bug 212509

Status

()

Firefox
Build Config
--
blocker
VERIFIED DUPLICATE of bug 212509
15 years ago
15 years ago

People

(Reporter: Roland Mainz, Assigned: Brian Ryner (not reading))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
2003-07-16-08-trunk pulled via CVS on Solaris2.7/SPARC build with Sun Workshop 7
in a seperate objdir/ - the build fails like this:
-- snip --
nsExternalHelperAppService.cpp
Building deps for
../../../src_2003-07-16-08-trunk/mozilla/uriloader/exthandler/nsExternalHelperAppService.cpp
/opt/SUNWspro/bin/CC -o nsExternalHelperAppService.o -c -DOSTYPE=\"SunOS5\"
-DOSARCH=\"SunOS\"  -I../../dist/include/xpcom -I../../d
ist/include/string -I../../dist/include/unicharutil
-I../../dist/include/mimetype -I../../dist/include/uriloader -I../../dist/includ
e/dom -I../../dist/include/necko -I../../dist/include/rdf
-I../../dist/include/webshell -I../../dist/include/helperAppDlg -I../../di
st/include/plugin -I../../dist/include/pref -I../../dist/include/intl
-I../../dist/include/uconv -I../../dist/include/windowwatcher 
-I../../dist/include/appcomps -I../../dist/include/history
-I../../dist/include/toolkitcomps -I../../dist/include/exthandler -I../..
/dist/include
-I/shared/bigtmp2/mozilla/nightlybuild_castor_phoenix_nightly_2003-07-16-08-trunk/objdir_static_2003-07-16-08-trunk/di
st/include/nspr     -I/usr/openwin/include     -I/usr/openwin/include
-xbuiltin=%all -mt  -DNDEBUG -DTRIMMED -xO2  -I/usr/openwin/in
clude -DSOLARIS=1 -DNSCAP_DISABLE_DEBUG_PTR_TYPES=1 -DD_INO=d_ino
-DSTDC_HEADERS=1 -DHAVE_ST_BLKSIZE=1 -DHAVE_SIGINFO_T=1 -DHAVE_INT
16_T=1 -DHAVE_INT32_T=1 -DHAVE_INT64_T=1 -DHAVE_UINT=1 -DHAVE_UINT_T=1
-DHAVE_UINT16_T=1 -DHAVE_DIRENT_H=1 -DHAVE_SYS_BYTEORDER_H=1 
-DHAVE_MEMORY_H=1 -DHAVE_UNISTD_H=1 -DHAVE_NL_TYPES_H=1 -DHAVE_MALLOC_H=1
-DHAVE_SYS_STATVFS_H=1 -DHAVE_SYS_STATFS_H=1 -DHAVE_LIBM=1
 -DHAVE_LIBDL=1 -DHAVE_LIBSOCKET=1 -DFUNCPROTO=15 -DHAVE_XSHM=1 -D_REENTRANT=1
-DHAVE_RANDOM=1 -DHAVE_STRERROR=1 -DHAVE_LCHOWN=1 -DH
AVE_FCHMOD=1 -DHAVE_SNPRINTF=1 -DHAVE_MEMMOVE=1 -DHAVE_RINT=1
-DHAVE_NL_LANGINFO=1 -DHAVE_FLOCKFILE=1 -DHAVE_LOCALTIME_R=1 -DHAVE_ST
RTOK_R=1 -DVA_COPY=va_copy -DHAVE_VA_COPY=1 -DHAVE_IOS_BINARY=1
-DHAVE_I18N_LC_MESSAGES=1 -DMOZ_DEFAULT_TOOLKIT=\"gtk\" -DMOZ_WIDGET
_GTK=1 -DMOZ_ENABLE_XREMOTE=1 -DMOZ_X11=1 -DMOZ_PHOENIX=1 -DMOZ_XUL_APP=1
-DMOZ_ENABLE_COREXFONTS=1 -DMOZ_EXTRA_X11CONVERTERS=1 -DOJ
I=1 -DIBMBIDI=1 -DACCESSIBILITY=1 -DMOZ_XPINSTALL=1 -DMOZ_JSLOADER=1
-DMOZ_MATHML=1 -DNS_DISABLE_LOGGING=1 -DMOZ_USER_DIR=\".mozilla
\" -DMOZ_XUL=1 -DMOZ_PROFILESHARING=1 -DMOZ_PROFILELOCKING=1 -DSUNCTL=1
-DMOZ_DLL_SUFFIX=\".so\" -DXP_UNIX=1 -DUNIX_ASYNC_DNS=1 -DJS
_THREADSAFE=1 -DNS_PRINT_PREVIEW=1 -DNS_PRINTING=1 -DMOZILLA_VERSION=\"1.5b\" 
-D_MOZILLA_CONFIG_H_ -DMOZILLA_CLIENT ../../../src_20
03-07-16-08-trunk/mozilla/uriloader/exthandler/nsExternalHelperAppService.cpp
"../../../src_2003-07-16-08-trunk/mozilla/uriloader/exthandler/nsExternalHelperAppService.cpp",
line 91: Error: Could not open inclu
de file "nsToolkitCompsCID.h".
1 Error(s) detected.
gmake[3]: *** [nsExternalHelperAppService.o] Error 1
gmake[3]: Leaving directory
`/shared/bigtmp2/mozilla/nightlybuild_castor_phoenix_nightly_2003-07-16-08-trunk/objdir_static_2003-07-1
6-08-trunk/uriloader/exthandler'
gmake[2]: *** [libs] Error 2
gmake[2]: Leaving directory
`/shared/bigtmp2/mozilla/nightlybuild_castor_phoenix_nightly_2003-07-16-08-trunk/objdir_static_2003-07-1
6-08-trunk/uriloader'
gmake[1]: *** [tier_9] Error 2
gmake[1]: Leaving directory
`/shared/bigtmp2/mozilla/nightlybuild_castor_phoenix_nightly_2003-07-16-08-trunk/objdir_static_2003-07-1
6-08-trunk'
gmake: *** [default] Error 2
-- snip --

Quick search with /usr/bin/find reveals that the file sits in the source dir but
the compiler cannot find it:
-- snip --
% find . -name "nsToolkitCompsCID.h" 
./src_2003-07-16-08-trunk/mozilla/toolkit/components/build/nsToolkitCompsCID.h
-- snip --
(Reporter)

Comment 1

15 years ago
This may be a regression due bug 107302 ...

Comment 2

15 years ago
Duplicate of a bug 400 bugs earlier: bug 212509.

*** This bug has been marked as a duplicate of 212509 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 3

15 years ago
v.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.