If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Middle-button click pastes clipboard

VERIFIED DUPLICATE of bug 7787

Status

()

Core
XUL
P3
normal
VERIFIED DUPLICATE of bug 7787
18 years ago
18 years ago

People

(Reporter: Peter Trudelle, Assigned: Mike Pinkerton (not reading bugmail))

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Go to a window with any editable text field (including URL bar- any page,
composer doc, new message)
Type "foo bar"
Select foo.
Copy.
select bar.
put cursor in edit field, and click middle button.
Note that it pastes the clipboard (foo), when it should copy the selection (bar)
and paste it. It should only paste the current clipboard if there is no selection.
(Assignee)

Updated

18 years ago
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 1

18 years ago
*** This bug has been marked as a duplicate of 7787 ***

Updated

18 years ago
Status: RESOLVED → VERIFIED

Comment 2

18 years ago
[bugday] verifying duplicate. middle click auto copying bug.
You need to log in before you can comment on or make changes to this bug.