Last Comment Bug 213079 - When severity or priority are hidden, CSS class names are incomplete in buglist
: When severity or priority are hidden, CSS class names are incomplete in buglist
Status: RESOLVED FIXED
:
Product: Bugzilla
Classification: Server Software
Component: Query/Bug List (show other bugs)
: 2.17.4
: All All
: -- normal (vote)
: Bugzilla 2.18
Assigned To: Christian Reis
: default-qa
Mentors:
: 118254 176526 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-07-18 07:52 PDT by Christian Reis
Modified: 2012-12-18 20:46 PST (History)
3 users (show)
justdave: approval+
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
kiko_v1: add severity and priority to default query (830 bytes, patch)
2003-07-18 07:57 PDT, Christian Reis
burnus: review+
Details | Diff | Splinter Review

Description Christian Reis 2003-07-18 07:52:04 PDT
When the severity or priority columns are hidden, CSS class names are incomplete
in buglist. Patch coming up
Comment 1 Christian Reis 2003-07-18 07:57:19 PDT
Created attachment 128015 [details] [diff] [review]
kiko_v1: add severity and priority to default query

How does this look?
Comment 2 Tobias Burnus 2003-07-18 08:18:05 PDT
*** Bug 176526 has been marked as a duplicate of this bug. ***
Comment 3 Christian Reis 2003-07-18 08:19:58 PDT
Tobias, can you give the patch a spin?
Comment 4 Dave Miller [:justdave] (justdave@bugzilla.org) 2003-07-19 20:06:10 PDT
Comment on attachment 128015 [details] [diff] [review]
kiko_v1: add severity and priority to default query

I want to research the impact of this a little...

I think you'll wind up with prority/severity twice if the user actually picked
it from their column list if you do this (and it'll probably cause an SQL error
under those circumstances).  I think there's more code in Search.pm you'll have
to touch to make this work right.
Comment 5 Christian Reis 2003-07-20 11:20:10 PDT
I am running this on our local bugzilla, with no negative effects so far (I
should have said I *did* test the patch). So I don't think any SQL problems
result from it.

If you take a look at the code in that area, you'll notice that selectcolumns
may very well have duplicate items: product and bug_status, for instance are in
displaycolumns, and *all* displaycolumns keys (except bug_id, which is removed
before) are added to selectcolumns. I don't think that's a problem; it seems
that Search.pm handles duplicate columns all right.

I think this fix is correct, and the impact to code is the lowest.
Comment 6 Tobias Burnus 2003-07-21 09:16:50 PDT
Comment on attachment 128015 [details] [diff] [review]
kiko_v1: add severity and priority to default query

Works ok here and looks ok.
Comment 7 Jeff Hedlund 2003-07-21 12:23:46 PDT
*** Bug 118254 has been marked as a duplicate of this bug. ***
Comment 8 Christian Reis 2003-07-21 12:46:46 PDT
Checked into trunk.

Funny that Jeff offered the exact same patch, over one year ago. Our radar isn't
very sharp, or Jeff isn't bothering enough people :-)

Note You need to log in before you can comment on or make changes to this bug.