Java Plug-in Error on Startup (Not Useragent Issue)

VERIFIED DUPLICATE of bug 83376

Status

()

defect
VERIFIED DUPLICATE of bug 83376
16 years ago
15 years ago

People

(Reporter: bugzilla, Assigned: peterlubczynski-bugs)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

16 years ago
User-Agent:       Mozilla/5.0 (compatible; MSIE5.5; Windows 98;
Build Identifier: Mozilla/5.0 (compatible; MSIE5.5; Windows 98;

I installed J2SE SDK 1.4.2 I started getting the following error on startup:

Java Plug-in Error

Java Plug-in for Netscape Navigator should not be used in Microsoft Internet
Explorer. Please use Java Plug-in for Microsoft Internet Explorer instead.

I was running an older copy of Mozilla so upgraded to 1.4. Still occurred.
Installed J2RE 1.4.1, still occurs. Uninstalled the JREs for 1.4.1 and 1.4.2 and
reinstalled 1.4.2 JRE. Still a problem.

Note, this looks similar to bug #83376 where the same thing occurs but it is due
to spoofing of the useragent string. For reference, this is the setting from my
prefs.js:

user_pref("general.useragent.override", "Mozilla/5.0 (compatible; MSIE5.5;
Windows 98;");

And this is what I get from a printenv call to a different machine

HTTP_USER_AGENT="Mozilla/5.0 (compatible; MSIE5.5; Windows 98;"

[Looking at that, there appears to be a missing bracket. I will try fixing that
and see what happens]

Note that even though this error occurs, it looks like Java still starts and the
console is viewable from the browser.

One more point, I made sure to set the plug-in to not use any proxies but is
connected directly to the internet (as is the browser)

Rich

Reproducible: Always

Steps to Reproduce:
1.Start browser
2.
3.

Actual Results:  
Got error

Expected Results:  
Not got error

Pinball theme
Reporter

Comment 1

16 years ago
By removing the user_pref line, I got a proper useragent string and it works OK. 

this is not an exact duplicate of bug 83376 which is for having something other
than "Mozilla/5" at the start of the string but it is still a "not recognising
useragent" issue so I'll mark it as a dupe.

Rich


*** This bug has been marked as a duplicate of 83376 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.