Failure to build from source

RESOLVED WORKSFORME

Status

--
blocker
RESOLVED WORKSFORME
16 years ago
14 years ago

People

(Reporter: T.Crane, Assigned: mozbugs-build)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/4.73 [en] (X11; U; Linux 2.4.19 i586)
Build Identifier: N/A

I cannot build Mozilla (downloaded this afternoon). My build script (as per the 
website build instructions) is as follows;

export CVSROOT=:pserver:anonymous@cvs-mirror.mozilla.org:/cvsroot
cvs co -f mozilla/client.mk
cd mozilla 
gmake -f client.mk

My system is Slackware Linux 7.1, with egcs-2.91.66, kernel 2.4.19 and glibc
2.1.3. The build log ends with;


c++ -I/usr/X11R6/include -fno-rtti -fno-exceptions -Wall -Wconversion
-Wpointer-arith -Wcast-align -Woverloaded-virtual -Wsynth -Wno-ctor-dtor
-privacy -pedantic -Wno-long-long -pthread -pipe  -DDEBUG -D_DEBUG -DDEBUG_tom
-DTRACING -g -fno-inline -I/usr/lib/glib/include -I/usr/X11R6/i
nclude  -fPIC -shared -Wl,-h -Wl,libgfx_gtk.so -o libgfx_gtk.so  nsPrintdGTK.o
gtkdrawing.o nsDeviceContextGTK.o nsDeviceContextSpecFactoryG.o
 nsDeviceContextSpecG.o nsDrawingSurfaceGTK.o nsGfxFactoryGTK.o
nsGraphicsStateGTK.o nsImageGTK.o nsGCCache.o nsRenderingContextGTK.o nsScreen
Gtk.o nsScreenManagerGtk.o nsPrintOptionsGTK.o nsFontMetricsUtils.o
nsAntiAliasedGlyph.o nsFontFreeType.o nsFT2FontNode.o nsFT2FontCatalog.o n
sX11AlphaBlend.o nsXFontAAScaledBitmap.o nsXFontNormal.o nsFontMetricsGTK.o
nsGdkUtils.o nsRegionGTK.o nsNativeThemeGTK.o              -Wl,-Bs
ymbolic -L../../../dist/bin -L../../../dist/lib -lgkgfx -lgfxshared_s 
-lgtksuperwin -L../../../dist/bin -lxpcom  -liberty -liberty -L../../..
/dist/bin -L/tmp/mozilla/dist/lib -lplds4 -lplc4 -lnspr4 -lpthread -ldl 
-L../../../dist/bin -lmozjs  -L/usr/lib -L/usr/X11R6/lib -lgtk -lgdk 
-rdynamic -lgmodule -lglib -ldl -lXext -lX11 -lm   -lxprintutil -L/usr/X11R6/lib
-lXp -lXext -lX11 -ldl -lm    
nsNativeThemeGTK.o: In function `GetPrimaryPresShell(nsIFrame *, nsIPresShell
**)':
/tmp/mozilla/gfx/src/gtk/nsNativeThemeGTK.cpp:105: undefined reference to
`nsIFrame::GetContent(nsIContent **) const'
nsNativeThemeGTK.o: In function `GetContentState(nsIFrame *)':
/tmp/mozilla/gfx/src/gtk/nsNativeThemeGTK.cpp:143: undefined reference to
`nsIFrame::GetContent(nsIContent **) const'
nsNativeThemeGTK.o: In function `CheckBooleanAttr(nsIFrame *, nsIAtom *)':
/tmp/mozilla/gfx/src/gtk/nsNativeThemeGTK.cpp:153: undefined reference to
`nsIFrame::GetContent(nsIContent **) const'
nsNativeThemeGTK.o: In function `CheckIntegerAttr(nsIFrame *, nsIAtom *)':
/tmp/mozilla/gfx/src/gtk/nsNativeThemeGTK.cpp:168: undefined reference to
`nsIFrame::GetContent(nsIContent **) const'
nsNativeThemeGTK.o: In function `nsNativeThemeGTK::GetGtkWidgetAndState(unsigned
char, nsIFrame *, GtkThemeWidgetType &, GtkWidgetState *, int
 *)':
/tmp/mozilla/gfx/src/gtk/nsNativeThemeGTK.cpp:209: undefined reference to
`nsIFrame::GetParent(nsIFrame **) const'
/tmp/mozilla/gfx/src/gtk/nsNativeThemeGTK.cpp:227: undefined reference to
`nsIFrame::GetParent(nsIFrame **) const'
/tmp/mozilla/gfx/src/gtk/nsNativeThemeGTK.cpp:228: undefined reference to
`nsIFrame::GetParent(nsIFrame **) const'
/tmp/mozilla/gfx/src/gtk/nsNativeThemeGTK.cpp:257: undefined reference to
`nsIFrame::GetContent(nsIContent **) const'
/tmp/mozilla/gfx/src/gtk/nsNativeThemeGTK.cpp:259: undefined reference to
`nsIFrame::GetParent(nsIFrame **) const'
/tmp/mozilla/gfx/src/gtk/nsNativeThemeGTK.cpp:345: undefined reference to
`nsIFrame::GetContent(nsIContent **) const'
nsNativeThemeGTK.o: In function
`nsNativeThemeGTK::ThemeSupportsWidget(nsIPresContext *, nsIFrame *, unsigned
char)':
/tmp/mozilla/gfx/src/gtk/nsNativeThemeGTK.cpp:586: undefined reference to
`nsIFrame::GetContent(nsIContent **) const'
collect2: ld returned 1 exit status
gmake[6]: *** [libgfx_gtk.so] Error 1
gmake[6]: Leaving directory `/tmp/mozilla/gfx/src/gtk'
gmake[5]: *** [libs] Error 2
gmake[5]: Leaving directory `/tmp/mozilla/gfx/src'
gmake[4]: *** [libs] Error 2
gmake[4]: Leaving directory `/tmp/mozilla/gfx'
gmake[3]: *** [tier_9] Error 2
gmake[3]: Leaving directory `/tmp/mozilla'
gmake[2]: *** [default] Error 2
gmake[2]: Leaving directory `/tmp/mozilla'
gmake[1]: *** [build] Error 2
gmake[1]: Leaving directory `/tmp/mozilla'
gmake: *** [build] Error 2

Apologies if this is known but I cannot find any reference to it in the Bugzilla
bug archive.

Thanks
Tom Crane.

Reproducible: Always

Steps to Reproduce:
N/A
Actual Results:  
See above

Expected Results:  
Built itself!

N/A

Comment 1

16 years ago
1) do a "make -f client.mk clean"
2) upgrade to atleast gcc-2.95

Comment 2

16 years ago
This could be transient bustage.  Were all of the tinderboxes green when you
attempted to build?  Have you tried updating the tree since then and attempted
to build again?  Finally, have you tried building using a milestone version of
the source tree (e.g. mozilla 1.4).

In response to McBride's comment, afaik, the problems with using egcs usually
results in an internal compiler error in xptcall.  Since the error occurred in
gfx, I don't think that's the problem.  Plus, when changing compilers or some
other system tool used by the build system, you'll need to do a 
'make -f client.mk distclean' before building again. (Note: distclean != clean)
(Reporter)

Comment 3

15 years ago
My thanks to Mathew and cls for the followup. I did not consult the tinderbox
settings -- this is the first time I've come across it. I simply
downloaded/updated the latest tree with cvs and tried building it as described
above. Previously I FTPed the complete 1.4 tarball and tried building that --
with and without the crypto option. In all cases the build failed at the same
point with the same error.

Trying to build gcc-3.3 gave problems, probably related to old libraries so I
gave up. 

For this and other reasons, I've more of less decided to cut my losses and
upgrade the distro -- which comes with a recent Mozilla binary.

In the meantime, if it is helpful to the Mozilla project, I'm happy to try again
building Mozilla with 1.5/other build options etc. 

Let me know...

Regards
Tom Crane

Comment 4

15 years ago
Since you've upgraded your distribution and the system components have changed,
I'm going to mark this worksforme unless someone else has the same configuration
to test with.  If you run into problems building again, please open a new bug.

Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 5

15 years ago
No. I've not upgraded yet and probably will not wipe the current distro for at
least a week. If there are any tests/rebuild attempts you would like me to try
in the meantime, then I'm happy to do so.

Regards
Tom Crane.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.