Text going the wrong direction when typing

RESOLVED DUPLICATE of bug 96057

Status

()

Core
Layout: Text
RESOLVED DUPLICATE of bug 96057
15 years ago
10 years ago

People

(Reporter: Yonatan Herzig, Assigned: mkaply)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.5b) Gecko/20030718
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.5b) Gecko/20030718

When I type messages in hebrew (I do so after I allign the text to the right, to
make it look a bit more hebrew-like) the text enteres just fine. But... hmm...
How can I describe it exactly? When I press the space bar, instead of going one
step away from the previous word, it for some reason goes to the beginning of
the line. The typing continues OK, but it seems like it pushes the whole line a
bit further. The most noticable problem this produces is that the full stops,
exclamation marks etc.. put in the end of the line will appear in it's beginning.

Reproducible: Always

Steps to Reproduce:
1. Start composing a new e-mail message
2. Align the text to the right
3. Start typing a message in hebrew (if you can) and see what happens

Actual Results:  
What is said aboved.

Expected Results:  
Act just like a word processor should act - move the cursor left each time I
type something instead of "attempting to go" to the right each time.
Setting right-alignment is the wrong way to set the text direction to
right-to-left. Unfortunately there currently is no right way.

*** This bug has been marked as a duplicate of 96057 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 2

15 years ago
shouldn't this be a dup of bug 119857?
a temporary workaround can be found here:
http://www.mozilla.org.il/support/faq.shtml (hebrew)
It's a dupe of 119857 if you are thinking of plain-text email, but of 96057 for
HTML mail.
Product: MailNews → Core

Updated

10 years ago
Component: MailNews: BiDi Hebrew & Arabic → Layout: Text
QA Contact: giladehven → layout.fonts-and-text
You need to log in before you can comment on or make changes to this bug.