Closed Bug 213204 Opened 17 years ago Closed 16 years ago

Internet Keywords: "www" and "net.au" added when trying to access localhost

Categories

(Firefox :: General, defect)

x86
Windows XP
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 178123

People

(Reporter: zarxos, Assigned: bugzilla)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4b) Gecko/20030516 Mozilla Firebird/0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4b) Gecko/20030516 Mozilla Firebird/0.6

In the Movable Type(movebletype.org) blogging software version 2.64, you must
access your preferences using a web browser at http://localhost. However, when I
try to access it, Firebird automatically redirects me to
http://www.localhost.net.au, an actual site on the web. I've tried using
127.0.0.1, but when I save preferences, Movable Type is programmed to use
localhost, so I'm sent back to localhost.net.au. Please take away the URL
autocomplete for localhost. I do not have this problem with Opera or IE.

Reproducible: Always

Steps to Reproduce:
1. Log in to movable type using 127.0.0.1
2. Open weblog config page and change whatever I need to
3. Click "save"

Actual Results:  
redirected to www.localhost.net.au

Expected Results:  
given confirmation message and sent back to the movable type prefs page
This also happens with other things on localhost, not just movable type
At the moment, firebird does a google-"I feel lucky"-search when you enter an
URL without www. or the domain-suffix

While this is normally a good thing, I agree that in the case of localhost, this
is a bad thing to do.

Confirming bug.
Status: UNCONFIRMED → NEW
Ever confirmed: true

*** This bug has been marked as a duplicate of 95390 ***
Status: NEW → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE
Mass-verifying. Sorry for bugspam.
Status: RESOLVED → VERIFIED
REOPEN: localhost is going to get its own bug.
Status: VERIFIED → REOPENED
QA Contact: asa → benc
Resolution: DUPLICATE → ---
Summary: www and .com added when trying to access localhost → Internet Keywords: www and .com added when trying to access localhost
I don't think that Moz should do anything special for localhost.  Conventions
says that localhost should be 127.0.0.1, but there isn't any RFC that defines it
as such, AFAICT.  It's perfectly legal (although stupid) to assign an IP address
other than 127.0.0.1 for localhost (except for WAIS and FILE protocols, which
handle it specially.)

The solution is to add localhost to your hosts file (which Windows should have
done automatically.)
Joe:

Do you have a webserver running on your system?

This redirection should only happen if your server is off.

If it happens when it is on, then that is a new (and possibly more serious
problem.).

Once we get this clarified, I can decide to dupe to bug 178123 or keep this as a
new problem.

Jerry: The problem with Internet Keywords and localhost is at a higher level. 
Lets have that conversation in the bug I mentioned above. 
tweeked summary too..

*** This bug has been marked as a duplicate of 178123 ***
Status: REOPENED → RESOLVED
Closed: 17 years ago16 years ago
Resolution: --- → DUPLICATE
Summary: Internet Keywords: www and .com added when trying to access localhost → Internet Keywords: "www" and "net.au" added when trying to access localhost
You need to log in before you can comment on or make changes to this bug.