Links from external programs open in javascript popup windows

RESOLVED DUPLICATE of bug 75138

Status

RESOLVED DUPLICATE of bug 75138
16 years ago
14 years ago

People

(Reporter: joe, Unassigned)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030529
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030529

When receiving a link from an external program in Windows, such as the Run
command in the start menu or an instant messenger, Mozilla appears to use the
last-used window or tab to display the link when it receives it. Not only is
this generally undesirable behaviour (at least for me), sometimes Mozilla will
open the link in a Javascript window popped up with window.open(). These windows
often lack toolbars and are part of the interface of the originating site, and
should therefore under no circumstances be used to launch links from external
programs.

Reproducible: Always

Steps to Reproduce:
These steps assume Mozilla is the default web browser on Windows 98 or later.

1. Open a new Mozilla window.
2. Visit my example page at http://pknet.com/~joe/foo.html .
3. Click the link to pop up a Javascript window.
4. Go to the "Run" command in the Start menu, and type a URL.
5. Click OK.
Actual Results:  
The URL from the Run dialog will launch in the Javascript window.


Expected Results:  
Ideally, there would be a setting to make links from external programs always
open in a new tab or window. But at the very least, windows spawned with
window.open should be flagged so that external links will not open in them.

*** This bug has been marked as a duplicate of 75138 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.