Closed Bug 21328 Opened 20 years ago Closed 20 years ago

[DOGFOOD] Enable network cache by default

Categories

(Core :: Networking: Cache, defect, P1)

defect

Tracking

()

CLOSED FIXED

People

(Reporter: fur, Assigned: gordon)

References

Details

(Whiteboard: [PDT-])

The code for the cache is in (except see pending fix for 21162, awaiting
review).  It's pref'ed out by default on all platforms.  I think we're ready to
flip the switch and turn on cache by default.

I haven't seen any problems on NT. Mac works also, but sdagley reports that the
throbber occasionally gets stuck on.  Pavlov reports good news on Linux too, but
he has a reproducible cache-related crash on one page. Enabled cache results in
a noticable speed improvement on all platforms.

If the default use of cache *does* cause problems for anybody, it can be
disabled by simply removing the cache dll from the components directory.

To enable the cache by default, ifdef or remove the code beginning at line 664
of nsHTTPChannel.cpp.
having verah add it to the m12 release notes.

we could tell the 85,000 milestones testers to flip
the pref and take a look and some good size %would
and report any problems to the network newsgroup,
or we could just turn it on.

fur, what say you... ;-)
The main reason to enable cache now is to make the product more usable,
moving us towards a DOGFOOD state, and not really to get more bug reports.  As
you say, adventurous milestone testers can provide enough feedback to stomp out
cache bugs without enabling the cache by default.
ok,  sounds like you want to turn it on as default now.
I'm up for that...  lets do it.
*** Bug 21327 has been marked as a duplicate of this bug. ***
I would like to get buy in from Warren, since the burden will fall on him as the
first line of defense on cache bugs.  (I'll still be available as a consultant,
of course.)

Also, I need a code review for #21162 before we enable the cache.
I think we should turn it on after m12, but post a release note for people that
want to try it out. That should raise the quality of any bug reports we
receive.
Whiteboard: [PDT-]
Let's wait till m12 closes; maybe post Dec15.
Bulk move of all Cache (to be deleted component) bugs to new Networking: Cache
component.
Assignee: chofmann → warren
Status: NEW → ASSIGNED
Target Milestone: M13
Warren, you absolutely should check in the fixes for 21660 before enabling the
cache by default.
Depends on: 21660
Assignee: warren → gordon
Status: ASSIGNED → NEW
-> Gordon
bug 21660 has been fixed, and we should now turn the
pref default to "on", leaving us an out (turning pref off)
in case some cache testing needs to happen.  We can yank
the pref/ifdef later.  It's trivial to change the pref default,
assign to me if you want me to do this.
Status: NEW → ASSIGNED
Priority: P3 → P1
I'm verifying the cache works properly on Mac, Windows, and Linux.  If it's okay,
then we can turn it on.
The cache was already tested on all three platforms a month ago.  Do you think
it has regressed ?
No, David and I are just trying to get a bit more familiar with it before we flip
the switch.
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
Cache is now enabled by default.
development issues - cache appears to be enabled - closing
Status: RESOLVED → CLOSED
You need to log in before you can comment on or make changes to this bug.