Closed Bug 213281 Opened 16 years ago Closed 16 years ago

make mozilla build with mingw gcc on win98 (windres no resources error)

Categories

(SeaMonkey :: Build Config, defect)

x86
Windows 98
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
mozilla1.6alpha

People

(Reporter: svl-bmo, Assigned: dmose)

References

()

Details

Attachments

(3 files)

Trying to build mozilla with mingw gcc on win98, I consistently rand into the
problem of windres giving a "no resources" error:

Creating Resource file: module.res
sh /cygdrive/e/building/home/mozilla/build/cygwin-wrapper windres -O coff
-DOSTYPE=\"WINNT4.0\" -DOSARCH=\"WINNT\" -D_IMPL_NS_COM -DEXPORT_XPT_API
-DEXPORT_XPTC_API -DEXPORT_XPTI_API --include-dir .. --include-dir
e:/building/home/mozilla/xpcom/build/../glue --include-dir
e:/building/home/mozilla/xpcom/build/../base --include-dir
e:/building/home/mozilla/xpcom/build/../ds --include-dir
e:/building/home/mozilla/xpcom/build/../io --include-dir
e:/building/home/mozilla/xpcom/build/../components --include-dir
e:/building/home/mozilla/xpcom/build/../threads --include-dir
e:/building/home/mozilla/xpcom/build/../threads/_xpidlgen --include-dir
e:/building/home/mozilla/xpcom/build/../proxy/src --include-dir
../../dist/include/string --include-dir ../../dist/include/xpcom --include-dir
../../dist/include --include-dir ../../dist/include/nspr -o module.res module.rc
Bad command or file name
e:\BUILDING\MINGW\BIN\windres.exe: no resources
make[4]: *** [module.res] Error 1


According to http://groups.google.com/groups?selm=114.1d19a26.28870de5%40aol.com
and followup, the error is windows' and the fix would be to use --use-temp-file
with windres. Adding this to  "RCFLAGS = -O coff"  in config/autoconf.mk seems
to fix. 
A proper patch will follow shortly.
Attached patch probable patchSplinter Review
So after futilly trying to diff against autoconf.mk for a bit, I figured out
that it's created during the build process. Both configure and configure.in
seem to define the flags for windres, so I've edited them both. 
autoconf.mk is now indeed created with --use-temp-file, so that seems to work
okay, but I have basically no idea what I'm doing here, so don't hit me too
hard if this isn't the right way or if I should've edited only one of the two
files. :)

I haven't yet succeeded in completing a build. But with this change at least
that windres error is being avoided.
Attachment #128155 - Flags: review?(dmose)
FWIW, I just ran into this problem on Win2000 when generating nspr.res.  I
haven't pinpointed the cause.  It only seemed to happen when building over a ssh
connection.  When I built from a local command window, then it worked fine.

Attachment #128155 - Flags: superreview?(leaf)
Attachment #128155 - Flags: review?(dmose)
Attachment #128155 - Flags: review+
Attached patch nspr & ldap tooSplinter Review
Attachment #128796 - Flags: superreview?(dmose)
Attachment #128796 - Flags: review?(wtc)
Comment on attachment 128796 [details] [diff] [review]
nspr & ldap too

r=wtc.
Attachment #128796 - Flags: review?(wtc) → review+
Comment on attachment 128155 [details] [diff] [review]
probable patch

rs=leaf
Attachment #128155 - Flags: superreview?(leaf) → superreview+
Attachment #128796 - Flags: review+
Attachment #128796 - Flags: superreview?(dmose) → review+
Attached patch coreconf as wellSplinter Review
Attachment #131476 - Flags: review?(wchang0222)
Comment on attachment 131476 [details] [diff] [review]
coreconf as well

r=wtc.

I've checked in this patch on the NSS trunk (NSS 3.9),
NSS_3_8_BRANCH (NSS 3.8.2), and NSS_CLIENT_TAG (Mozilla
1.6 alpha).
Attachment #131476 - Flags: review?(wchang0222) → review+
The patches have all been checked in: 
mozilla trunk
nspr trunk
ldap trunk
nspr NSPRPUB_PRE_4_2_CLIENT_BRANCH
ldap ldapcsdk_50_client_branch
Status: NEW → RESOLVED
Closed: 16 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.6alpha
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.