CSS style on OPTION of a dropbox are not used when the item is selected

RESOLVED DUPLICATE of bug 79107

Status

()

--
minor
RESOLVED DUPLICATE of bug 79107
15 years ago
15 years ago

People

(Reporter: dralion, Assigned: bugzilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4b) Gecko/20030516 Mozilla Firebird/0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4b) Gecko/20030516 Mozilla Firebird/0.6

When you assign a unique identifier to an OPTION in a Select drop box (an ID)
and you change the background color, the option is well displayed in the drop
but when you select it, you loose your style.

Reproducible: Always

Steps to Reproduce:
1. Add this to your head tag :

<style type="text/css">
#test1			{background-color: #CDE5EB; color: black;}
#test2			{background-color: #F7F8C0; color: black;}
</style

2. Add this in your body tag :

<select name="a_test" size="1">
	<option id=test1 value="1">test number 1</option>
	<option id=test2 value="1">test number 2</option>
</select>

3. Try it. 
Actual Results:  
The background colors are good when the dropbox opens but when you select an
item and close it, you loose the background color.

Expected Results:  
The background color of the OPTION should be displayed in the dropbox.

-

Comment 1

15 years ago

*** This bug has been marked as a duplicate of 79107 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.