Receiving Junk Mail triggers Mail Notification: It shouldn't

VERIFIED DUPLICATE of bug 189289

Status

SeaMonkey
MailNews: Message Display
--
enhancement
VERIFIED DUPLICATE of bug 189289
14 years ago
9 years ago

People

(Reporter: James Sams, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030624
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030624

when moz mailnews receives a new email, it first notifies the user that s/he has
new mail, then checks for junk status and acts accordingly.  This turn of events
is incorrectly ordered.  The system should first check for junk status. Those
messages marked junk _should_NOT_ trigger new mail notification events.  

This is a more specific example of a more general feature request.  Mail
notification should be able to be made conditional.  So, mail that gets hit by
certain user-set filters should be allowed to set no new notification (this
might best be done as an extension of the filter capabilities).  

Furthermore, separate icons/sounds should be able to be set for different
accounts/filters.

This is broadly speaking a single issue, though I guess it could be split into
several bug filings.  I will file issues separately if it is thought wise.

Reproducible: Always

Steps to Reproduce:
1. Enable Mail Notification
2. Receive Junk Mail (if you don't have this problem, sign up for hotmail/yahoo
account, use a hotmail/yahoo POP3 proxy program to get mozilla to check that mail)

Actual Results:  
3. Watch Mail notification icon popup for every porn, viagra, vacation, etc. ads
that you receive when you could care less.

Expected Results:  
Mail marked as junk should not trigger any alert to the user.

Comment 1

14 years ago

*** This bug has been marked as a duplicate of 189289 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Verified dup
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey

Updated

9 years ago
Component: MailNews: Notification → MailNews: Message Display
QA Contact: stephend → search
You need to log in before you can comment on or make changes to this bug.