If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Absolute positioned form elements (select, input etc.) not rendered when form element defined as inline and relative

RESOLVED FIXED

Status

()

Core
Layout: R & A Pos
RESOLVED FIXED
14 years ago
3 years ago

People

(Reporter: Iain Wells, Unassigned)

Tracking

({testcase})

Trunk
x86
All
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5a) Gecko/20030718
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5a) Gecko/20030718

<html>
	<head>
		<title>Mozilla Bug Using An Inline Relative Form Element</title>
	</head>
	<body>

		<h1>Mozilla Bug Using An Inline Relative Form Element</h1>
		<table>
			<tr>
				<td colspan="2">
					The following is a table cell containing a relative postioned form within
which are absolute positioned select and input elements layered over each other:
				</td>
			</tr>
			<tr>
				<td width="70">
					Enter Text:
				</td>
				<td width="160">
					<form style="position:relative;">

						<select style="position:absolute;top:0px;width:150px;">
							<option value="">One</option>
							<option value="">Two</option>
							<option value="">Three</option>
						</select>

						<input type="input" value="Testing"
style="position:absolute;top:0px;width:132px;">
						</input>

					</form>
				</td>
			</tr>
			<tr>
				<td colspan="2">
					&nbsp;
				</td>
			</tr>
			<tr>
				<td colspan="2">
					The following contains the same code but with the form defined to be
displayed inline so as not to use block element spacing. This results in the
form not being rendered at all probably somthing to do with the fact that a
relative positioned element becomes a block element automatically:
				</td>
			</tr>
			<tr>
				<td width="70">
					Enter Text:
				</td>
				<td width="160">
					<form style="position:relative;display:inline;">

						<select style="position:absolute;top:0px;width:150px;">
							<option value="">One</option>
							<option value="">Two</option>
							<option value="">Three</option>
						</select>

						<input type="input" value="Testing"
style="position:absolute;top:0px;width:132px;">
						</input>

					</form>
				</td>
			</tr>
			
		</table

	</body>
</html>


Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Actual Results:  
The form and its elements are not rendered.

Expected Results:  
Displayed the form with inline spacing.

Please let me know if you need the test file emailed to you or made available on
the web.
(Reporter)

Comment 1

14 years ago
Btw, this worked up to and including v1.0.2 
Depends on: 135082
Created attachment 128345 [details]
reporter's testcase

Comment 3

14 years ago
Created attachment 128381 [details]
Testcase #2

Comment 4

14 years ago
I think this is a dupe of an earlier "rel. pos. overflow not visible" bug.
Assignee: block-and-inline → position
Status: UNCONFIRMED → NEW
Component: Layout: Block & Inline → Layout: R & A Pos
Ever confirmed: true
Keywords: testcase
OS: Windows 2000 → All
Whiteboard: DUPEME

Comment 5

14 years ago
Bug 210746 or bug 135082 looks similar...

Comment 6

14 years ago
FIXED by roc's checkin for bug 235778.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED

Updated

4 years ago
Whiteboard: DUPEME
Created attachment 8556281 [details]
incorrect_position_input_form.png
You need to log in before you can comment on or make changes to this bug.