false rendering of <q> tag

RESOLVED DUPLICATE of bug 16206

Status

()

Core
Layout: Text
--
major
RESOLVED DUPLICATE of bug 16206
15 years ago
15 years ago

People

(Reporter: Jörg Hartmann, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de-DE; rv:1.4b) Gecko/20030516 Mozilla Firebird/0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de-DE; rv:1.4b) Gecko/20030516 Mozilla Firebird/0.6

The <q></q> tag is falsely rendered within both Mozilla and
Firebird, especially in German, French and Swiss-German.

For instance, <q lang="de" xml:lang="de">Beispiel</q> should give
„Beispiel“, not "Beispiel".

Also in English, <q lang="en" xml:lang="en">example</q> would better
result in “example” than in "example".

The W3C clearly states that language specific quotation markes should be
rendered (whereby language means real language, not ASCII-nonsense).

Reproducible: Always

Steps to Reproduce:
1. Create a web page
2. Use the <q> tag
3. Render the page with Mozilla 1.4 and/or Firebird 0.6

Actual Results:  
Always got "" instead of the language specific, correct left and right quotation
marks.

Expected Results:  
render at least „Beispiel“ for <q lang="de"
xml:lang="de">Beispiel</q> and, to be perfect, “example”
for <q lang="en" xml:lang="en">example</q>

Well, and «» for French and »« for Swiss-German.

This is a real, true bug, believe me. (At least in German, French and
Swiss-German. English PC users are used to ASCII "", although that's bad, wrong
English and is never used in goog books or news papers.)

Comment 1

15 years ago

*** This bug has been marked as a duplicate of 16206 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.