Tab key navigation focus lost when moving to previous or next page in history

VERIFIED DUPLICATE of bug 36539

Status

()

defect
VERIFIED DUPLICATE of bug 36539
16 years ago
a month ago

People

(Reporter: sylerner, Assigned: aaronlev)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030624
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030624

Tab key navigation focus is lost when you use history navigation (alt-left) to
return to a page.  This should be retained as part of the state of the window
that is restored when navigating backwards and forwards through the history list.

If I tab to a link and hit enter to follow the link, and then either hit
backspace or alt-left_arrow to return to the page that I was just at, when I hit
tab it doesn't go to the next link/button/etc. after the one that I just
visited.  Instead, tab navigation always starts at the top of the page.

I often naviagate pages where I wish to visit each link in turn.  I should be
able to tab to a link, visit it, return to the previous page, hit tab, and then
visit the next page in the list.  Instead, I have to keep tabbing from the top
of the page, which can be very time consuming if there are many links on the page.

Reproducible: Always

Steps to Reproduce:
1.Tab to a link (not the first one on the page) and hit enter
2.Hit backspace or Alt-LeftArrow
3.Hit tab in an attempt to go to the link after the one you just visited

Actual Results:  
You visit the first link or button on the screen regardless of which link was
last clicked or tabbed to when the screen was last displayed.

Expected Results:  
You should have gone to the next link or button AFTER the one that you just
visited (i.e. - the one where focus was when you left the screen)

*** This bug has been marked as a duplicate of 36539 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
Component: Keyboard: Navigation → User events and focus handling
Product: Core → Core
You need to log in before you can comment on or make changes to this bug.