.pac file format specification for daterange() is inconsistent!

VERIFIED DUPLICATE of bug 213699

Status

Documentation
Help Viewer
VERIFIED DUPLICATE of bug 213699
15 years ago
15 years ago

People

(Reporter: maxnitribitt, Assigned: rudman)

Tracking

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)
Build Identifier: 

auto-proxy file format specification :
( http://wp.netscape.com/eng/mozilla/2.0/relnotes/demo/proxy-live.html )
states, that daterange() can handle those
combinations of arguments:
8<------------------>8
dateRange(day)
dateRange(day1, day2)
dateRange(mon)
dateRange(month1, month2)
dateRange(year)
dateRange(year1, year2)
dateRange(day1, month1, day2, month2)
dateRange(month1, year1, month2, year2)
dateRange(day1, month1, year1, day2, month2, year2)
dateRange(day1, month1, year1, day2, month2, year2,
gmt)
[...]
Even though the above examples don't show, the "GMT"
parameter can be specified in any of the 9 (sic!)
different call profiles, always as the last parameter.

  
8<------------------>8
In the examples section there is one call that doesn't
match these call profiles:
8<------------------>8
This statement is true on the 24th of December, 1995.
dateRange(24, "DEC", 1995) 
8<------------------>8
Is the call profile collection incomplete, or is this
a fake example? Could anyone please shed some light
into this matter?


Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Comment 1

15 years ago

*** This bug has been marked as a duplicate of 213699 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 2

15 years ago
v
Status: RESOLVED → VERIFIED
QA Contact: rudman → stolenclover
You need to log in before you can comment on or make changes to this bug.