file:// URL not accessed when clicked

RESOLVED DUPLICATE of bug 122022

Status

SeaMonkey
General
RESOLVED DUPLICATE of bug 122022
15 years ago
13 years ago

People

(Reporter: Alan Ellenberger, Unassigned)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.3) Gecko/20030312
Build Identifier: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.3) Gecko/20030312

If an URL like file://///host/share/dir1/dir2/blabla.dot is accessed (clicked)
on a webpage, the file (a Word .dot in this case) is not accessed.

If, alternatively, you right-click the link and choose "Save Link Target As
...", a "Save As" dialog is opened.


Reproducible: Always

Steps to Reproduce:

Actual Results:  
The link is not even attempted to be fetched.

Expected Results:  
The file:// link should be retrieved as always, as if it were a normal link.

Comment 1

15 years ago
This is deliberate.  Please:

1) Read the release notes before filing a bug.
http://www.mozilla.org/releases/mozilla1.4/known-issues.html#psm

2) Don't open a bug on a version more than 2 weeks old.

3) Look for duplicates before filing a bug.

*** This bug has been marked as a duplicate of 122022 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

15 years ago
Thanks for the reply.

Regarding your points.

1) Sorry, I should have read them first.

2) I *did* test it on a newer build but didnt mention that in the bug report.
Our bad.

3) I did search for duplicated but didn't find that bug.

The current (security-related) behaviour seems okay, though what I would like to
see is that a message appears (and not only in the javascript console).
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.