Closed Bug 213900 Opened 17 years ago Closed 17 years ago

Messed up Content-Type header leads to problems

Categories

(Core :: Networking: HTTP, defect)

x86
Linux
defect
Not set

Tracking

()

VERIFIED DUPLICATE of bug 210229

People

(Reporter: bzbarsky, Assigned: darin.moz)

References

()

Details

(Whiteboard: DUPEME)

Attachments

(1 file)

Loading this page is wacky in a lot of ways... but the important thing is that
loading it wipes out the NSPR HTTP log (like overwrites it with a bunch of zero
bytes).  I used wget to fetch it (_maybe_ getting the same headers, who knows)
and the headers look like:

Content-Type: text/html; charset=Shift_JIS,ISO-8859-1

The header is certainly causing some of the wackiness (dialogs, etc) and _may_
be responsible for the NSPR log being wiped.  My concern for this bug is the
NSPR log thing itself, though -- that just should not happen.
OK, forget the NSPR log.  That's bug 213923

The only remaining issue here is the header issue, and I seem to recall seeing
existing bugs on that....
Severity: critical → normal
Summary: Much wackiness when loading page -- NSPR log wiped → Messed up Content-Type header leads to problems
Whiteboard: DUPEME
Sir, I'm glad that I can help with the duping. Sorry for the slow response :-)

*** This bug has been marked as a duplicate of 210229 ***
Status: NEW → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE
Ah, yes.  That's the one.  Thank you!
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.