Shockwave/flash plugins causes 99% cpu usage in idle mozilla client on Linux and W2K.

RESOLVED DUPLICATE of bug 238935

Status

()

Core
Plug-ins
--
major
RESOLVED DUPLICATE of bug 238935
14 years ago
12 years ago

People

(Reporter: Sunil, Assigned: Peter Lubczynski)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030624
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030624

If the pages contain flash/shockwave presetations and mozilla has plugins
installed, after few hours of use, CPU load reaches 99% when nothing is being
done in the browser and stays there. The system becomes unusable for other
things. So, normally I rename stuff in plugin dir, reload all tabs and open an
IE for sites(e.g. comcast.net, my email site) which have all their content
accessible only as shockwave/flash presentation. I hate to use IE and that's why
I am logging this bug.

Reproducible: Always

Steps to Reproduce:
1. Open few yahoo pages which have shockwave/flash ads(actually most have them).
Also visit comcast.net.
2. Use browser as you normally would.
3. After few hours of use, CPU load reaches 99% when nothing is being done in
the browser and stays there.
4. Goto plugins directory and rename or remove libraries, so plugins are
ineffective. Now reload all tabs. Idle CPU usage comes down to 3-4%.

Actual Results:  
After few hours of use, CPU load reaches 99% when nothing is being done in the
browser and stays there. The system becomes unusable for other things.

Expected Results:  
Constant CPU usage should never be allowed to go beyond a threshold like 10%.
Whether it is thru some sort of periodic self-check & destroy spinning on CPU
threads or user initiated plugin disabling. Mozilla can provide one-button
disable feature for all plugins, instead of user going to plugins directory and
renaming the plugins. This is a major concern because most sites have started
offering their contents as shockwave/flash presentations and I have to use IE to
get decent performance on my system. 

This behaviour reproduces on W2K and Linux with latest released version of the
mozilla browser.

I wish I had enabled dump support so I could provide you some dumps.
(Reporter)

Updated

14 years ago
Severity: normal → major

Comment 1

14 years ago
I've been having the same problem.  The build I'm using is:
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7b) Gecko/20040421
Shockwave Flash 7.0 r19

There is an interesting behavior to note.  CPU usage is a just under 30% when
the flash object is covered by another window, or scrolled out of the visible
area.  When the object is visible, and the mouse is not over it usage floats in
the 70 - 78% range.  Bringing the mouse over the object usage shoots to almost 100%.

Currently http://news.com.com/ has an Intel Flash ad at the top right of the
page that produces this problem.
The same page in IE6 does not have this issue.

I don't know if this is a browser or a plugin issue.  The bug should be confirmed

Comment 2

13 years ago
Looks like a dupe of bug 238935, which has more comments than this one.

Comment 3

13 years ago
it seems multiple flash ads contribute to 99% CPU usage such as in this page
http://news.teamxbox.com/comments/8015/Microsoft-Announces-Publishers-Committed-to-Deliver-Content-for-NextGeneration-Xbox-Platform/

I'm on a trunk build, Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2)
Gecko/20050406 Firefox/1.0+
Depends on: 139751

Comment 4

12 years ago

*** This bug has been marked as a duplicate of 238935 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.