Closed Bug 213977 Opened 17 years ago Closed 17 years ago

A newly opened tab should mirror the current webpage

Categories

(SeaMonkey :: Tabbed Browser, enhancement)

x86
Windows XP
enhancement
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 18808

People

(Reporter: bugzilla, Assigned: jag+mozilla)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5b) Gecko/20030725
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5b) Gecko/20030725

Currently, when you click 'Open a new tab', the new tab opened is just a blank
page, with no URL.  Why not have the same behaviour as IE, which is that when
you open a new tab, the webpage displayed in the currently selected tab is
immediately displayed in the new tab too?  You shouldn't need to load the
webpage again, because it's in local cache.

For people wanting the new tab to navigate to another page, this behaviour is no
inconvenience to them; they'd have had to type in the URL they wanted to visit
anyway.  For people wanting to 'fork' their browsing of the current website,
this is very very useful.  I know you can right click 'open page in new tab',
but this is slightly different and still useful.

Reproducible: Always

Steps to Reproduce:
1. Go to a webpage.
2. Click 'Open a new tab'.

Actual Results:  
New tab is blank, no URL.

Expected Results:  
New tab should have the same URL as currently selected tab, and the current
webpage should be mirrored.
IE has that feature for new window and I hate it,
but for tabs you can use Tabbrowser extensions
http://texturizer.net/firebird/extensions.html#Tabbrowser%20Extensions
it has a "Duplicate Tab" function
> IE has that feature for new window and I hate it

Why?  What possible inconvenience does it cause?

And why shouldn't this be the default Mozilla behaviour.  I think it should.
*** This bug has been marked as a duplicate of 18808 ***

*** This bug has been marked as a duplicate of 18808 ***
Status: UNCONFIRMED → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE
I hate that IE feature because there's no way to disable it

actually mozilla kind of does this already:
goto Edit > Preferences > Navigator > Display on "New Tab" (select from dropdown
menu) and click "Last page visited" radio button.
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.