RealOne Player used as a helper application cause Mozilla and Firebird to crash

RESOLVED FIXED

Status

Core Graveyard
File Handling
--
critical
RESOLVED FIXED
14 years ago
a year ago

People

(Reporter: Paul Bergsagel, Assigned: Bill Law)

Tracking

Trunk
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.5b) Gecko/20030724
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.5b) Gecko/20030724

I attempted to watch a RealOne movies. When I clicked on the URL to launch
Mozilla as a helper application the browser quit.

Reproducible: Always

Steps to Reproduce:
1.Go to http://www.movieflix.com/movie_info.mfx?movie_id=359. Go to the link
"Macintosh & Unix Users: Narrowband \ Broadband".
2.Click on Broadband.
3.Mozilla will quit and fail to launch the RealOne player.

Actual Results:  
Mozilla quits and fails to launch RealOne player.

Expected Results:  
Mozilla should play the RealOne content.

After Mozilla (and RealOne?) have quit I notice that a RealOne file has been
downloaded which when launched will paly the RealOne content.
-> File Handling
Assignee: general → law
Component: Browser-General → File Handling
QA Contact: general → petersen

Comment 2

14 years ago
Paul, do you have the box "Always ask me before
handling files of this type" in "Preferences..." --> "Navigator" --> "Helper
applications" checked?

If so, can you reproduce the problem with other file types?

What version of Mac OS X are you running? Can you post a mac os x crash log?
(Reporter)

Comment 3

14 years ago
I am using MacOS X 1.5. I did not have the box "Always ask...." when dealing
with helper apps checked. I do not have a crash log. I do not have any version
of Mozilla 1.5 on my hard drive anymore since 1.5 was very unstable and twice
corrupted my user profile (fortunately I had a backup of the profile). 

Untile I find that the stability and safety (i.e.no profile corruption) of
running Moz 1.5x on MacOS I will not load any version of Mozilla higher than Moz
1.4.

I would like to investigate this bug further, but until the stability of Moz 1.5
improves, I don't want to go through the headaches required to "fix" my system
after Moz 1.5x corrupts my Mozilla setup.
Depends on: 213639
this should be fixed now (from bug 213639 checkin)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.