Commas in Content-Type headers cause great confusion

RESOLVED DUPLICATE of bug 210229

Status

()

Firefox
General
--
minor
RESOLVED DUPLICATE of bug 210229
15 years ago
15 years ago

People

(Reporter: Thomas Thurman, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5a) Gecko/20030715 Mozilla Firebird/0.6
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5a) Gecko/20030715 Mozilla Firebird/0.6

Going to http://www.hometown.aol.com (or, AFAICS any other page on that site)
makes FB put up a dialogue saying:

  The file "" is of type iso-8859-1, and Mozilla Firebird does not know
  how to handle this file type.

and asking what viewer application to use, where to save the file, and so on.

A little investigation shows that the server is sending

  Content-Type: text/html; charset=Shift_JIS,ISO-8859-1

which is non-RFC2045 compliant (the "Shift_JIS,ISO-8859-1" should be quoted,
since it contains a comma). However, FB breaks so spectacularly on this that
it's difficult to view any page on the site.

This is certainly an evangelism issue, but FB could perhaps use a little
do-what-I-mean here as well.

Reproducible: Always

Steps to Reproduce:
1. Go to http://www.hometown.aol.com

Comment 1

15 years ago

*** This bug has been marked as a duplicate of 210229 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.