TopCrash [@ _Z19ComputeAlphasByByteiiiPhS_iS_j][@ ComputeAlphasByByte]

RESOLVED WORKSFORME

Status

()

P1
critical
RESOLVED WORKSFORME
15 years ago
2 months ago

People

(Reporter: timeless, Assigned: roc)

Tracking

({crash, topcrash})

Trunk
x86
Linux
crash, topcrash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

15 years ago
_Z19ComputeAlphasByByteiiiPhS_iS_j   8 
BBID range: 22133129 - 22186635 
Min/Max Seconds since last crash: 3 - 1586 
Min/Max Runtime: 12 - 1589 
Crash data range: 2003-07-23 to 2003-07-25 
Build ID range: 2003071815 to 2003071815 

Stack Trace: 

         _Z19ComputeAlphasByByteiiiPhS_iS_j() 
         _ZN9nsBlender9GetAlphasERK6nsRectPvS3_PPh() 
         _ZN13nsViewManager11RenderViewsEP6nsViewR19nsIRenderingContextRK8nsRegioni() 
         _ZN13nsViewManager7RefreshEP6nsViewP19nsIRenderingContextP9nsIRegionj() 
         _ZN13nsViewManager13DispatchEventEP10nsGUIEventP13nsEventStatus() 
         _Z11HandleEventP10nsGUIEvent() 
         _ZN8nsWidget13DispatchEventEP10nsGUIEventR13nsEventStatus() 
         _ZN8nsWidget19DispatchWindowEventEP10nsGUIEvent() 
         _ZN8nsWindow7DoPaintEP9nsIRegion() 
         _ZN8nsWindow6UpdateEv() 
         _ZN8nsWindow10UpdateIdleEPv() 
         libglib-1.2.so.0 + 0x13cff (0x402cccff) 
         libglib-1.2.so.0 + 0x143ee (0x402cd3ee) 
         libglib-1.2.so.0 + 0x14199 (0x402cd199) 
         libglib-1.2.so.0 + 0x13174 (0x402cc174)     (22186635) Comments: just tried to load Mozilla 1.5 beta  and recieved this agent... have not been able to run 1.5 since installing it... oh well. 
     (22151028) Comments: just did an installation - crashed on initial startup [end of installation process]. I suspect this relates to my having aquaMoz installed on 1.4. 
     (22139049) URL: mozdev.org 
     (22139049) Comments: installing a theme
demangled stack:
         ComputeAlphasByByte(int, int, int, unsigned char*, unsigned char*, int,
unsigned char*, unsigned)()
         nsBlender::GetAlphas(nsRect const&, void*, void*, unsigned char**)()
         nsViewManager::RenderViews(nsView*, nsIRenderingContext&, nsRegion
const&, int)()
         nsViewManager::Refresh(nsView*, nsIRenderingContext*, nsIRegion*,
unsigned)()
         nsViewManager::DispatchEvent(nsGUIEvent*, nsEventStatus*)()
         HandleEvent(nsGUIEvent*)()
         nsWidget::DispatchEvent(nsGUIEvent*, nsEventStatus&)()
         nsWidget::DispatchWindowEvent(nsGUIEvent*)()
         nsWindow::DoPaint(nsIRegion*)()
         nsWindow::Update()()
         nsWindow::UpdateIdle(void*)()
Yikes! This should never be called at all.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P1
Is this still showing up?

It possibly could have been caused by people trying the transparent chrome stuff.
Depends on: 202751
(Reporter)

Comment 4

15 years ago
Not listed in:
Simple Crash Analysis Trunk Builds - all

 This report was generated on 10/30/03 and contains 10 days of data.
(Reporter)

Comment 5

15 years ago
wfm since there weren't any reports. i'll reopen if i notice this in talkback if
talkback ever returns :).
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
Crash Signature: [@ _Z19ComputeAlphasByByteiiiPhS_iS_j] [@ ComputeAlphasByByte]
Component: Layout: View Rendering → Layout: Web Painting
Product: Core → Core
You need to log in before you can comment on or make changes to this bug.