Closed Bug 214393 Opened 19 years ago Closed 15 years ago

Changing the visited link color doesn't work.

Categories

(Core :: CSS Parsing and Computation, defect)

x86
Windows 2000
defect
Not set
normal

Tracking

()

RESOLVED FIXED

People

(Reporter: mike, Unassigned)

References

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5a) Gecko/20030728 Mozilla Firebird/0.6.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5a) Gecko/20030728 Mozilla Firebird/0.6.1

I change the visited link color but the color doesn't change.  The form where
you make the change shows that the change was registered.  But when you look at
links that were visited, they show in the original purple instead of the new
color.  This functionality should work.  I want to make the visited link color
so that visited links are more obvious to me.

Reproducible: Always

Steps to Reproduce:
1.Select Tools then Options menu
2.Select Fonts and Colors.
3.Click the visited links button and change the color.  
4.Look at a page showing visited links.

Actual Results:  
The visited links were purple.

Expected Results:  
The visited links should be in the new color.
Depends on: 168326
in fact the new prefs stylesheet just doesn't have any effect on any existing
browser views. (works in new tabs though)
Assignee: firefox → dbaron
Status: UNCONFIRMED → NEW
Component: History: Global → Style System (CSS)
Ever confirmed: true
QA Contact: chrispetersen → ian
The problem here is that changing the prefs rebuilds the pref stylesheet, blows
away all the cached style data, and reflows.  It does NOT reresolve style.  It
needs to, since it rebuilt the sheet.

We need to split up the prefs into those that are handled by the prefs
stylesheet (which need just a call to PresShell::ReconstructStyleData()) and
those that directly affect style computation (which need a call to
nsPresContext::ClearStyleDataAndReflow).  At the moment, we handle the latter
correctly (eg minimal font size), but not the former.

I suppose we could do both or something, but that's twice the work, making
closing prefs even slower.  I'd rather fix bug 168326 first (hence the dependency).
Assignee: dbaron → nobody
QA Contact: ian → style-system
WFM with
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9b4pre) Gecko/2008022204 Minefield/3.0b4pre
This got fixed by bug 386640.
Depends on: 386640
Flags: in-testsuite?
Thanks.

-> FIXED
Status: NEW → RESOLVED
Closed: 15 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.