Profile manager fails to create Japanese user

VERIFIED DUPLICATE of bug 15264

Status

P2
critical
VERIFIED DUPLICATE of bug 15264
19 years ago
3 years ago

People

(Reporter: amasri, Assigned: selmer)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
with Mozilla 1999120708, Win98 Ja:

1. Delete mozregistry.
2. Launch seamonkey
3. Create new profile with japanese characters
4. quit
5. Relaunch seamonkey

RESULT: seamonkey fails to recognize japanese username; user is asked to create
a new profile.
(Reporter)

Updated

19 years ago
Severity: normal → critical
Priority: P3 → P2
(Assignee)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 1

19 years ago
Or any other non-ascii name - duplicate.

*** This bug has been marked as a duplicate of 15264 ***

Updated

19 years ago
Status: RESOLVED → REOPENED

Updated

19 years ago
Resolution: DUPLICATE → ---

Comment 2

19 years ago
Steve, can we start tracking profile manager issues separately? For QA is hard
to verify a bug as general as "Make Profile manager I18n friendly". Maybe we
should make a dependency from this one to the general one (15264), but we
shouldn't consider it a dup. Reopening.
(Assignee)

Comment 3

19 years ago
I don't see a compelling reason to carry 2 bugs for the same problem.  I don't
see how we could implement a Ja only solution and also implement a separate
general solution that's different.  If I let you leave this one open, then I'll
anticipate getting another one for every language anyone cares about.  I'm
_really_ unexcited about carrying a bunch of bugs for a single fix!

If you can convince me otherwise, I'll leave this open.  Failing that I'm going
to mark it a dup again on Monday.

Comment 4

19 years ago
Actually, I don't mean one per language, I mean different bugs for Profile
Manager having to do with Intl. For example, this bug refers to not being able
to create a profile with a JA name. The next one, after the name is created, can
be, not able to delete a profile with a JA name, or not able to rename a profile
with a JA name, or who knows what other combination. At some point, we may
have specific Chinese or Korean problems, but that's far ahead. These were bugs
in 4.5, that's why I'd like to keep them separate. And they can be under the
bigger umbrella of "friendliness" for tracking purposes, but for QA they have to
be separate bugs, because that's what they are. How is this for convincing you?
;-)
(Assignee)

Updated

19 years ago
Status: REOPENED → RESOLVED
Last Resolved: 19 years ago19 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 5

19 years ago
You're still complaining about the mural before we've even built the wall to
paint it on.  It doesn't make sense to file bugs against features that haven't
been implemented yet.  Once bug 15264 is fixed, try this again.  If it still
doesn't work at that time, then you can file this bug.

*** This bug has been marked as a duplicate of 15264 ***

Updated

19 years ago
Status: RESOLVED → VERIFIED

Updated

19 years ago
Component: Profile Manager → Profile Manager BackEnd

Comment 6

19 years ago
Moving all Profile Manager bugs to new Profile Manager Backend component.
Profile Manager component to be deleted.
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.