All users were logged out of Bugzilla on October 13th, 2018

Web Links are not case sensitive

RESOLVED DUPLICATE of bug 176312

Status

()

RESOLVED DUPLICATE of bug 176312
15 years ago
15 years ago

People

(Reporter: behold_argos, Assigned: bugzilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5a) Gecko/20030728 Mozilla Firebird/0.6.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5a) Gecko/20030728 Mozilla Firebird/0.6.1

Web Links do not appear to be case sensitive in Firebird, while they are in IE6.
Background info: Our local network webserver has a homepage that contains a
sidebar of useful links. I wrote a set of online forms for local company use. 
Links to these html pages are on the sidebar. When the user opens the homepage
in IE6 the links will work fine, but when they try and use Firebird 0.6.1 they
do not.  The online form pages are on a Linux server thus the links need to be
case sensitive.
In IE6 the link shows up as:
http://.../IRindex.html This link works in IE6
but in Firebird 0.6.1 the links is:
http://...\irindex.html/ and this link takes the user to an error page.


Reproducible: Always

Steps to Reproduce:
1.load page in IE6 and it works
2.load page in Firebird 0.6.1 and it fails
3.compare links note case difference

Actual Results:  
Links will work in IE6 and not in firebird

Expected Results:  
The links should be read as case sensitive and should link properly.

Comment 1

15 years ago
This works in general.  For example, the link from
http://www.mozilla.org/projects/security/components/ to
http://www.mozilla.org/projects/security/components/ConfigPolicy.html works
correctly.  Can you give us the URL of the page where it doesn't work?  Or save
a copy, make sure the saved version still exhibits the problem, and upload it? 
(I'm using Firebird 07/30 on WinXP, btw.)
(Reporter)

Comment 2

15 years ago
The problem:
This is the actual working link:
http://originalsid.mcqassociates.com/~workflow/STORindex.html

This is the way Firebird interprets the link:
http://originalsid.mcqassociates.com\~workflow\storindex.html

It has become aware to me that it may in fact not be the letter case that is the
problem, but the '\' instead of '/' as well.

Comment 3

15 years ago
Please check the source of the site to make sure the link includes / rather than
\.  Mozilla does not convert \s in links into /s like IE does (see bug 32895).

Comment 4

15 years ago
I'm still baffled about the case conversion, though.  I've never seen Mozilla do
that.
(Reporter)

Comment 5

15 years ago
ok, it looks to me like what was happening was this:
Firebird interpreted the link up until the '\' then it got ... we'll say
confused and for whatever reason stopped caring about case.
I say this because after going to the sys admin and having the '\' changed to
'/' (like they should have been all along) Firebird now sees the link as:
http://originalsid.mcqassociates.com/~workflow/STORindex.html
Thus i conclude the '\' char must have caused the case confusion.

Comment 6

15 years ago

*** This bug has been marked as a duplicate of 176312 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.