Vertical-align: bottom for images a little off

VERIFIED INVALID

Status

()

P3
normal
VERIFIED INVALID
19 years ago
19 years ago

People

(Reporter: christinehoff4, Assigned: pierre)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments)

(Reporter)

Description

19 years ago
Using the 1999121008 build - tested on Win 95, Win NT, Win 98, Mac8.5 and Linux
Red Hat 6.0 (Linux 2.2).

Steps to reproduce:
Open the attached file with images

Expected result: Two images should be bottom aligned
Actual result: Right image is a bit higher at the bottomthan left image.

Behavior is across platform. Nav aligns images correctly
(Reporter)

Comment 1

19 years ago
Created attachment 3401 [details]
Testcase to demonstrate problem
(Reporter)

Comment 2

19 years ago
Created attachment 3402 [details]
1st image to go with testcase
(Reporter)

Comment 3

19 years ago
Created attachment 3403 [details]
2nd image to go with testcase
(Assignee)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → INVALID
(Assignee)

Comment 4

19 years ago
The display is correct. The first image has the "vertical-align: bottom" style,
so it is aligned to what would be the bottom line for the text, if some text were
present. The second image has no style attached to it, so it is aligned to the
base line of any text that could be there.

I understand that my explanations may be a bit confusing so see the new testcase
that I'm going to attach. Closing as invalid.
(Assignee)

Comment 5

19 years ago
Created attachment 3533 [details]
2nd testcase that shows how it works
(Reporter)

Updated

19 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 6

19 years ago
Yes, I see that since the second image does not have a vertical align style set,
it defaults to baseline which will not align the images evenly. Another problem
then might be related to Nav quirks. Will take this issue offline with assigned
engineer.
You need to log in before you can comment on or make changes to this bug.