Site Navigation bar doesn't disappear when not needed when changing tabs

RESOLVED DUPLICATE of bug 207463

Status

RESOLVED DUPLICATE of bug 207463
15 years ago
14 years ago

People

(Reporter: 6mjjmugn96, Unassigned)

Tracking

Trunk
Sun
SunOS

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.4) Gecko/20030701
Build Identifier: Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.4) Gecko/20030701

If the Site Navigation Bar is set to show only when needed and some of the tabs
in the current browser window need it, it will remain hidden until one of the
tabs is selected that needs it.  It then turns on.  If another tab is then
selected which does not need it, it does not go away.  This is true even if the
new tab was selected by closing the tab that needed the Site Nav bar.  The bar
will then go away upon first navigation in the tab that doesn't need it (unless,
of course, the page navigated to does need it).

Reproducible: Always

Steps to Reproduce:
1.Open a new tabbable browser window
2.Select View->Show/Hide->Site Navigation Bar->Show Only As Needed
3.In the initial tab (call it tab A), open a site that does not use Site Nav
4.Open a new tab (tab B)
5.Open a site in tab B that needs Site Nav
6.Select tab A
7.Navigate to another page in tab A that does not use Site Nav

Actual Results:  
After step 6, the Site Nav bar does not go away.
After step 7, the Site Nav bar does go away.

Expected Results:  
After step 6, the Site Nav bar should go away.
After step 7, there should be no Site Nav bar to go away.

Comment 1

15 years ago
WFM, 2003-08-01-05 trunk Linux

Comment 2

15 years ago

*** This bug has been marked as a duplicate of 207463 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.