Closed Bug 214877 Opened 16 years ago Closed 16 years ago

styles applied to col or colspan ignored

Categories

(Core :: Layout: Tables, defect)

x86
Windows XP
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 4510

People

(Reporter: ac, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5a) Gecko/20030718
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5a) Gecko/20030718

Colors specified by giving a col or colspan a class (or ID) and applying a
background color are ignored by Mozilla (v1.0 to 1.5a).
Also, mozilla seems to ignore the aligments set via the same method for <th>
elements. I think it happens even styles are applied inline (no case handy), so
seems to be a general failure to apply styles to cols.

Initially I thought I was doing something wrong, but it validates, is supported
by the W3C specs, and works in every other V5+ browser. Having to apply a style
to every table cell in a column would create unnecessarily bulky code,
especially since it has support from the other popular browsers.
OK, the page isn't pretty, but the colours have purpose!

Reproducible: Always

Steps to Reproduce:
1.Go to a page with stlyles applied via columns. E.g. background colours.
2.
3.

Actual Results:  
Columns have white background

Expected Results:  
Columns have coloured backgounds. Applied colours from style sheet.

*** This bug has been marked as a duplicate of 4510 ***
Status: UNCONFIRMED → RESOLVED
Closed: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.