windows closes by itself

RESOLVED DUPLICATE of bug 212298

Status

()

RESOLVED DUPLICATE of bug 212298
15 years ago
13 years ago

People

(Reporter: mozilla, Unassigned)

Tracking

({testcase})

Trunk
x86
Windows 2000
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5a) Gecko/20030718
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5a) Gecko/20030718

after clicking on a link the window simply closes.
going directly to the offending url (https://mycard.fleet.com/cma/login.do) does
not cause the window to close
clicking on the link and picking 'Open in new window' does not cause the window
to close either



Reproducible: Always

Steps to Reproduce:
1. www.fleet.com
2. quick links -> Credit Cards -> Go -> takes you to http://cards.fleet.com
3. Login (upper right)

Actual Results:  
the current open window closes

Comment 1

15 years ago
This is the offending code in https://mycard.fleet.com/cma/login.do (you can
access it by diabling javascript before loading the window)

   //If this is a pop up window we want to close this window and redirect its parent
   var parentWin;
   if(window.opener != null)
   {
      parentWin = window.opener;
      if(parentWin.isCMAWindow != null)
      {
         if(parentWin.isCMAWindow)
         {
            //The parent of this window is a CMA window, therefore we need to
close ourselves
            //and redirect the parent
            parentWin.location = window.location;
            window.close();
         }
      }
   }

(Reporter)

Comment 2

15 years ago
from https://mycard.fleet.com/cma/login.do:
     //Set a top level variable so that our children know that this is a CMA window
     isCMAWindow = true;

it looks like CMAWindow is not mentioned in any of the previous pages in the
sequence (fleet.com or cards.fleet.com)

this leads me to believe that fome some reason window.opener points back to the
current window, correct ?

if I understand http://www.mozilla.org/docs/dom/domref/dom_window_ref77.html
correctly, then window.opener should return NULL in this case since all the
activities are conducted in a single window

Comment 3

15 years ago
Yes, I think just the same, but I don't know why it has opener!=null
(Reporter)

Comment 4

15 years ago
Using the js debugger I verified that window.opener points to the current window
(via window.opener.location)

I can reproduce this only if I start from fleet.com (going to the url directly
works fine)

from http://www.fleet.com/includes/global.js:
function hyperJump(dropNum) { // This function controls that crazy dropdown nav
	selection = "select"+dropNum;
	formname = "form"+dropNum;
	newURL =
document[formname][selection].options[document[formname][selection].selectedIndex].value;
		window.open(newURL,"_top");
}


so I guess this is one of those window.open() weirdnesses...

were you able to reproduce this ?
(Reporter)

Comment 5

15 years ago
Created attachment 130120 [details]
page1 of the testcase
(Reporter)

Comment 6

15 years ago
Created attachment 130121 [details]
page2 of the testcase
(Reporter)

Comment 7

15 years ago
I've uploaded 2 simple pages that can be used to reproduce this.
Simply stick them in the same directory and open page1.

This still seems to not work correctly for me with
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5b) Gecko/20030819

Comment 8

15 years ago
-> DOM
Assignee: general → general
Component: Browser-General → DOM
QA Contact: general → ian

Comment 9

15 years ago
I see this exact same behavior using both Mozilla (Mozilla/5.0 (Windows; U;
Windows NT 5.0; en-US; rv:) Gecko/20040307 MultiZilla/1.6.2.1d) and Firefox
(Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7b) Gecko/20040310
Firefox/0.8)

Peace...

Comment 10

15 years ago
Ok, I've sent a link to this bug report to the Fleet.com web developers through
the fleet.com site.

Peace...

Comment 11

15 years ago
Build ID 2004050708 (both Mac OS X and Win98): I found the same behavior of this
page, however I want to add a new "feature" of this:

If you are on <http://cards.fleet.com/>, you can reach the page that closes
itself by clicking on the orange link in the upper right corner "Login" which
brings you to <http://mycard.fleet.com/>.
a) If I just click on the link, the new window closes.
b) If I do right-click and then "Open Link in New Window", then the page stays
open and works!

Is this now an error in Fleet's JS code, or one of Mozilla?
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/
(Reporter)

Comment 13

13 years ago
fleet.com has been redisigned (not necessarily for the better), but the current
open window still closes using the prevoiusly provided test case with
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20050915
Firefox/1.0.7

Comment 14

13 years ago
Fleet is now Bank of America, and the page looks completely different. I cannot
reproduce this bug anymore really. Can you give an example?
(Reporter)

Comment 15

13 years ago
yes, download the two attachments, open page1 and click on the link

Comment 16

13 years ago
Confirmed: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1)
Gecko/20050929 Firefox/1.6a1
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: testcase

*** This bug has been marked as a duplicate of 212298 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.