XLoadQueryFont() failure causes glyphs to disappear even if another font has these glyphs

RESOLVED WONTFIX

Status

Core Graveyard
GFX
--
critical
RESOLVED WONTFIX
15 years ago
3 years ago

People

(Reporter: Roland Mainz, Assigned: Jungshik Shin)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
XLoadQueryFont() failure (e.g. |XLoadQueryFont()| returns NULL) causes glyphs to
disappear even if another font has these glyphs.
This seems to be a quite common problem on Mandrake and Debian Linux... ;-(

Steps to reproduce:
1. Copy /usr/X11R6/lib/X11/fonts/TTF/ to /tmp/TTF/
2. Edit fonts.dir and add a clone each line like this:
  -- snip --
  a1
  a2
  b1
  b2
  ...
  -- snip --
3. Rename [a-z]1 file entry to a non-existing file
4. Add /tmp/TTF at the front of the Xserver's font path
5. Run Mozilla

Result:
Many glyphs are missing since all the [a-z]1 XLFD entries causes
|XLoadQueryFont()| to fail - and Mozilla does not seem to try further entries...
;-((

Expected results:
Mozilla should try more entries until a font is found which can be instantiated
(e.g. |XLoadQueryFont()| returns a valid font handle).
(Reporter)

Updated

14 years ago
Assignee: bstell → jshin
Product: Core → Core Graveyard
This bug has been buried in the graveyard and has not been updated in over 5 years. It is probably safe to assume that it will never be fixed, so resolving as WONTFIX.

[Mass-change filter: graveyard-wontfix-2014-09-24]
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.