"Find Again" option fails to work correctly when viewing Page Source

RESOLVED DUPLICATE of bug 205815

Status

()

Firefox
General
--
minor
RESOLVED DUPLICATE of bug 205815
15 years ago
15 years ago

People

(Reporter: Chris Gibson, Assigned: David Hyatt)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.5a) Gecko/20030728 Mozilla Firebird/0.6.1
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.5a) Gecko/20030728 Mozilla Firebird/0.6.1

When I view the source of any webpage, either from the toolbar or by pressing
Apple-U, I can correctly search the source for a keyword by using the "Find in
This Page..." option. I can also correctly find further examples of the keyword
by clicking "Find Next" in the "Find in This Page..." dialog.

However, if I close/cancel the dialog I am unable to "Find Again" for the same
keyword, either by choosing "Edit -> Find Again" or by pressing Apple-G. There
is no error message, eg "The text you entered was not found". Instead, the
option simply has no apparent effect.

The same problem does not exist when searching web pages [ie, when not viewing
the source]. When searching web pages, Find Again works as expected.

Reproducible: Always

Steps to Reproduce:
1. Go to a webpage such as www.google.com.
2. Choose "View -> Page Source", or press Apple-U.
3. Choose "Edit -> Find in This Page...", or press Apple-F. 
4. Enter a search term in the dialog that is known to exist in the source, such
as 'google'.
5. Press "Find Next" a few times to verify existence of search term.
6. Press cancel to close dialog.
7. Select "View -> Find Again", or press Apple-G.
Actual Results:  
Nothing. No apparent effect.

Expected Results:  
Located and highlighted further instances of the keyword in the source if
present, or returned a "The text you entered was not found" message if not
present. There is no apparent effect in either case.

This is my first ever bugzilla submisssion, so apologies for any errors or
omissions.

Comment 1

15 years ago
happening for me as well, 0.6.1 milestone.  someone with more power can mark
confirmed.

Comment 2

15 years ago
I'm seeing this also with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US;
rv:1.5b) Gecko/20030804 Mozilla Firebird/0.6.1
Confirming based on comments below.

--> hyatt
Assignee: blake → hyatt
Status: UNCONFIRMED → NEW
Ever confirmed: true
With Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4b; MultiZilla
v1.4.0.3J) Gecko/20030728 Mozilla Firebird/0.6.1, JavaScript Console shows:
Error: BrowserFindAgain is not defined

Comment 5

15 years ago

*** This bug has been marked as a duplicate of 205815 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.