Closed Bug 215232 Opened 17 years ago Closed 9 years ago

missing "window:*" events

Categories

(Core :: Disability Access APIs, defect)

x86
Linux
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla5

People

(Reporter: rd, Assigned: fherrera)

References

(Blocks 1 open bug)

Details

Attachments

(1 file, 1 obsolete file)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030206
Build Identifier: http://ftp25moz.newaol.com/pub/mozilla/accessibility/redhat7.3/2003-07-25/

If an app is listening for window events from mozilla, it will never receive
such events.



Reproducible: Always

Steps to Reproduce:
1.start mozilla
2.start an app which is listening for "window:*" events (eg gnopernicus).
3.

Actual Results:  
No window events ("window:*").

Expected Results:  
All window events (window:minimize, window:destroy, etc).
We need to make sure someone from Sun's Brower ATF team is CC'd on these bugs (are they 
aleady part of gnome-access-bugs?)
Assignee: aaronl → kyle.yuan
Bug 235719 added support for the window:activate and window:deactivate events
(needed for GOK) and added the framework to support other at-spi window events,
but they have not been implemented yet.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Assignee: yuanyi21 → pete.zha
QA Contact: dsirnapalli → accessibility-apis
Fernando, anything to do here?
We are firing window:activate and window:deactivate events. Not for:
- window:maximize
- window:create
- window:restore

Should we?
Perhaps we should ping Joanie on this.
Whiteboard: [does anybody care?]
Interesting. I always assumed that window manager goodness was responsible for this sort of thing rather than the application or toolkit.

Regardless, personally I tend towards complete implementations (rather than suggesting consumers should just listen to other events and/or determining something is not worth implementing due to lack of ping response. ;-) ). After all, even if Orca is not (currently) listening for those events, some other AT might have a need for them.
(In reply to comment #4)
> We are firing window:activate and window:deactivate events. Not for:
> - window:maximize
> - window:create
> - window:restore

Fernando, so these events aren't fired for Firefox windows (by window manager per comment 6)?
I'm not seeing these events.

And for what it's worth, I wasn't saying that the window manager did this; merely that I assumed it did. I am often wrong. ;-)
not so often :)

ok, then we should fire them, nsWindow should be suitable place for that if we can get accessible for window.
No, is the toolkit implementation the one that should fire these events. What gail does is to listen for gtk "window-state-event" and then firing window:maximize / window:minimize / window:restore / window:create / window:destroy
This patch fires maximize/restore/minimize events for native windows that we block gail implementation (toplevel windows). Other native windows (print dialog, open file dialog, etc...) should get them fired by gail.

We are still missing the create/destroy events.
Assignee: zhayupeng → fherrera
Notice that for our toplevel windows, we have gail listeners, but they are not doing anything because they check for object type to be GTK_WINDOW / GAIL_WINDOW type.
Comment on attachment 518680 [details] [diff] [review]
Wip for sending missing window events


>+        nsRootAccessible *rootAcc =
>+          static_cast<nsRootAccessible *>(accessible);
>+        rootAcc->mActivated = PR_FALSE;

these lines are wrong, coming from a copy & paste error. Just ignore them
This patch includes create and destroy signals for toplevel windows.
However I cannot see the event "window:destroy" coming from the at-spi registry, event if the bridge is sending it correctly. Actually, I cannot see any "window:destroy" event from any gtk application so it could be an at-spi registry bug.
Attachment #518680 - Attachment is obsolete: true
Attachment #518689 - Flags: superreview?(roc)
Attachment #518689 - Flags: review?(ginn.chen)
Whiteboard: [does anybody care?]
> Actually, I cannot see
> any "window:destroy" event from any gtk application so it could be an at-spi
> registry bug.

No, it was properly propagated, but a bug on pyatspi prevented my event log application from catching it:

https://bugzilla.gnome.org/show_bug.cgi?id=644492
Attachment #518689 - Flags: superreview?(roc) → superreview+
Attachment #518689 - Flags: review?(ginn.chen) → review+
Blocks: a11ynext
Whiteboard: [has patch]
Keywords: checkin-needed
Whiteboard: [has patch]
http://hg.mozilla.org/mozilla-central/rev/a1cae3aa90d7
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Whiteboard: fixed-in-cedar
Target Milestone: --- → mozilla2.2
Depends on: 669253
You need to log in before you can comment on or make changes to this bug.