[gfx scrollbar] thumb scrolls past mousedown in scroll area

VERIFIED DUPLICATE of bug 22512

Status

()

Core
XUL
P4
normal
VERIFIED DUPLICATE of bug 22512
18 years ago
18 years ago

People

(Reporter: Cesar Eduardo Barros, Assigned: David Hyatt)

Tracking

Trunk
All
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
When I left-click on the empty space above/below the scrollbar (you know, the
"PgUp/PdDn" area), it works normally as pageup or pagedown -- except when after
the movement the sliding box is below the mouse. When it happens, the
pageup/pagedown action is "stuck", and it goes on until it reaches the
top/bottom of the document. Clicking on the pageup/down area again fixes it
(unless after this click the mouse ends up again above the sliding box -- then
the same mess happens again in the opposite direction. This is very common on
short pages, and is annoying since the keyboard shortcuts don't work in some
builds in a random fashion -- some builds have the PgUp/PgDn keys working,
others don't).

Also, middle-clicking in the sliding box makes the mouse get "stuck" -- it moves
the page up and down even after you released the button and left the scrollbar
area. Clicking on the page background with the _left_ button is the only way to
unstuck the movement.

Current build here is 1999121108, but I've seen this weird behavior for some
builds (since about M10 IIRC -- I don't follow the builds closely).

Updated

18 years ago
Assignee: trudelle → evaughan
Severity: minor → normal
Hardware: PC → All
Summary: Annoying scrollbar behavior → [gfx scrollbar] thumb scrolls past mousedown in scroll area

Comment 1

18 years ago
This bug has been reproduced on all platforms with the 1999121208 builds.
To repro get any page that's a couple screenfuls long or shrink your window.
With the thumb at the top of the window click and hold in the middle of the
scroll area. The thumb (and pae scroll) will race past the moue until it reaches
the bottom of the window.

Updated

18 years ago
Priority: P3 → P4
Target Milestone: M14

Comment 2

18 years ago
targetting p4 m14

Comment 3

18 years ago
This only happens in trees. Hyatt are you setting the current pos to be greater 
than the max pos?
Assignee: evaughan → hyatt
Target Milestone: M14 → M15
(Assignee)

Comment 4

18 years ago

*** This bug has been marked as a duplicate of 18193 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 5

18 years ago
I don't think this is actually a duplicate of 18193, unless it's a duplicate at 
a technical level I don't understand (likely), but it does seem to be resolved 
at least for the most part, and at least for the win32 builds.
(Assignee)

Comment 6

18 years ago
Ok, are you seeing this in scrollbars other than scrollbars attached to tree 
views?  Try bringing up www.mozilla.org and scrolling it.  Do you see this 
problem.  If the answer is yes, reopen the bug and give it back to evaughan.  If 
the answer is no, that you only see it in tree scrollbars, then it is a dup, 
since it only happens because the scrollbar gets out of whack on trees, and 
that's what the other bug refers to.

Comment 7

18 years ago
Confirmed that this is still happening with browser window GFX scrollbars on NT, 
for ordinary HTML pages.

This looks a *lot* more like bug 22512, "Clicking just below scrollbar thumb 
moves thumb to bottom", blocker, M14, dogfood, not one of yours at all, hyatt. 
REOPENing to change DUP.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---

Comment 8

18 years ago

*** This bug has been marked as a duplicate of 22512 ***
Status: REOPENED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → DUPLICATE

Comment 9

18 years ago
VERIFIED dupe. there are two slightly different behaviors that are i believe similar but unrelated. they both are mentioned in this 
bug. One issue is dealt with in bug 22512 the other in bug 26914
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.