Page loads in other tabs with dialog boxes steal cursor focus

RESOLVED DUPLICATE of bug 200950

Status

SeaMonkey
Tabbed Browser
--
minor
RESOLVED DUPLICATE of bug 200950
15 years ago
10 years ago

People

(Reporter: Kyle Bieneman, Assigned: Joe Francis)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4b) Gecko/20030516 Mozilla Firebird/0.6
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4b) Gecko/20030516 Mozilla Firebird/0.6

When loading a page with a dialog box, if one opens a new tab while the page in
the old tab is still loading, the page will take the cursor focus away, so
anything typed shows up in the dialog box in the old tab, rather than the URL
bar of the new tab.

Reproducible: Always

Steps to Reproduce:
1. Type "http://mail.yahoo.com" in the url bar and hit enter
2. Quickly press Ctrl+t to open a new tab
3. Type "hello world"
Actual Results:  
"hello world" appears in the Yahoo ID field in the first tab.

Expected Results:  
"hello world" should appear in the url bar for the new tab.

I believe this bug is OS and version independent, I recall having seen it before
on other machines (running different OSes and different versions of Mozilla).

Comment 1

15 years ago
Confirmed on WinXP Moz 2003080304.

I think this is more suited to Tabbed Browsing.

->Tabbed Browsing
OS->All
Status: UNCONFIRMED → NEW
Component: Editor: Core → Tabbed Browser
Ever confirmed: true
OS: Linux → All

Comment 2

15 years ago

*** This bug has been marked as a duplicate of 200950 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.