"Close Other Tabs" should not be last item in Tab context menu

VERIFIED FIXED

Status

()

Firefox
Toolbars and Customization
VERIFIED FIXED
15 years ago
12 years ago

People

(Reporter: Ben Goodger (use ben at mozilla dot org for email), Assigned: David Hyatt)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Close Other Tabs is too easy to hit (resulting in unwanted action) at the bottom
of the menu. I move that "Close Tab" should be the bottom and "Close Other Tabs"
should be above it.

Comment 1

15 years ago
Hyatt fixed that 12 hours ago.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Component: General → Toolbars
QA Contact: asa → bugzilla
Resolution: --- → FIXED

Comment 2

15 years ago
verified fixed 2003-11-09
Status: RESOLVED → VERIFIED
Tim: http://bugzilla.mozilla.org/show_bug.cgi?id=191578#c68 is OK.

My only problems with it is that people will have to pass over "Close other
tabs" to get to "Close tab". Its also a big mouse movements they have to make
for the most (or maybe second most) commonly used option. Its also more prone to
accidental releases for handicapped people.

http://bugzilla.mozilla.org/show_bug.cgi?id=191578#c67 is no good because it
puts "Close other tabs" where "Close tabs" used to be. This would be OK if Jag
doesn't dig his heals about seperation of the close items:

+----------------+
|New Tab         |
+----------------+
|Close Tab       |
|Reload Tab      |
+----------------+
|Close Other Tabs|
|Reload All Tabs |
+----------------+

If you look at it, its logical that you have the two destructive close and
reload options in the same area and the actions on all tabs in the same area and
they are ordered the same in each area.


ken:

There is no "new tab" button (see bug 186865) on Firefox and we should have
consistent menus between Firefox and Seamonkey. 

> Please keep "close tab" at the top and move "close other tabs" as far away 
> from it as possible.  That's my 2 cents.  Thanks.

"close tab" shouldn't be at the top for slippage as I already said. In my
example above, its second from the top.
Status: VERIFIED → REOPENED
Resolution: FIXED → ---
Taking.
Status: REOPENED → ASSIGNED

Updated

14 years ago
Assignee: hyatt → netdemonz
Status: ASSIGNED → NEW
Sorry about the bugspam, I accidentally clicked the link to the wrong bug and
since their summaries are almost identical, I didn't realize it. Back to Hyatt.
Assignee: netdemonz → hyatt

Updated

14 years ago
Status: NEW → RESOLVED
Last Resolved: 15 years ago14 years ago
Resolution: --- → FIXED

Updated

14 years ago
Status: RESOLVED → VERIFIED

Comment 6

14 years ago
Brian, new to this submitting patches thing... does "taking" mean that you
intend to go ahead and do this change?

Just clarifying.

Thanks.

Comment 7

14 years ago
ha.  Maybe I shouldn't even comment because I am running with Mozilla 1.5.

But anyway...

I will miss that "new tab" button a lot, and so I have one more incentive
*not* to upgrade.  I will upgrade, of course, when my *real interest* in this
matter, the abominable, non-undoable, non-confirmed "close other tabs" option,
is fixed.

Comment 8

14 years ago
#7, the "New Tab" button is still there in Firefox, it just has to be placed on
the Bookmarks Toolbar instead of the Tab Toolbar. I was a little hesitant to
this when first switching to Firefox as well, but it took all of about 1 hour to
get used to shifting my mouse up about 40 pixels. After that there's no problem.

Brian, should I submit the patch here, even though it's still left as "VERIFIED
FIXED"?
Reordering discussions to:
http://forums.mozillazine.org/viewtopic.php?p=512622#512622

I was hastily trying to get the discussions out of that other bug before it gets
spammed out, but clicked on the wrong bug to move it to. Mozillazine is better.
*** Bug 306960 has been marked as a duplicate of this bug. ***

Updated

12 years ago
QA Contact: bugzilla → toolbars
You need to log in before you can comment on or make changes to this bug.