Automated product change causing exceeded vote count prevents subsequent user vote change.

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
16 years ago
5 years ago

People

(Reporter: jasonb, Unassigned)

Tracking

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5b) Gecko/20030804
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5b) Gecko/20030804

I recently became the "proud owner" of having 12 votes in the Browser product.
I'd voted for 10 Browser bugs (my maximum) but had two of my other voted bugs
change product to Browser.  I then discovered that I now actually have 12 votes
against Browser products (over the maximum) when I went to "un-vote" for one of
the bugs that had been resolved FIXED.

I can't stop voting for it, however, because Bugzilla won't let me keep the
(then) existing 11 votes which would be over the limit.  It wasn't my fault that
the products changed on me.

In one sense, this is a loophole in the system, and I could look at it as being
privileged to currently enjoy having more votes than I should be allowed.  But,
in another sense, my thinking is that having this kind of automatic change
happen to me is almost like a bait and switch tactic because I can't now clean
up my votes properly without being penalized for doing so (by losing a vote that
I previously enjoyed).

Bugzilla should only be checking the vote limit when you try to *add* a vote,
not when you try to *remove* one.

Reproducible: Always

Steps to Reproduce:

Comment 1

14 years ago
Because of the way process_bug.cgi and Bug::RemoveVotes actually work, Bugzilla
*has* to check the total number of votes even when you remove votes. What
happened to you will soon not be possible anymore, see bug 34172. Your exceeding
votes will automatically be removed.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 2

14 years ago
I don't actually think that a WONTFIX is a valid resolution.  More
appropriately, bug 34172 should be set as blocking this one, and this one FIXED
when that one is FIXED.

Although, I suppose a WONTFIX is appropriate for the actual Summary, the intent
of the bug is that I don't want the system to leave me in a state where I can't
change my votes.  Once bug 34172 is fixed, that won't be the case any more and
I'll be able to reassign as I wish.
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---
Summary: Vote count should only be checked when adding a bug, not removing one. → Automated product change causing exceeded vote count prevents subsequent user vote change.
(Reporter)

Updated

14 years ago
Depends on: 34172

Comment 3

14 years ago
This summary is much better! ;) I'll mark this bug as fixed together with bug 34172.
Assignee: myk → create-and-change
Status: REOPENED → NEW
OS: Windows XP → All
QA Contact: mattyt-bugzilla → default-qa
Hardware: PC → All

Comment 4

14 years ago
*** Bug 217240 has been marked as a duplicate of this bug. ***

Comment 5

12 years ago
So was this actually fixed by bug 34172? If so it should be marked as such.
This bug was fixed by bug 34172.
Status: NEW → RESOLVED
Last Resolved: 14 years ago5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.