Crash on startup after compiling with gcc 2.95.2

RESOLVED DUPLICATE of bug 213839

Status

SeaMonkey
General
--
critical
RESOLVED DUPLICATE of bug 213839
15 years ago
14 years ago

People

(Reporter: Martin Wulffeld, Unassigned)

Tracking

({crash})

Trunk
x86
Linux
crash

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
If I compile latest cvs I get the following error on startup:

mw@mw:/mozilla/src/cvs/mozilla/dist/bin$ ./run-mozilla.sh ./mozilla
Type Manifest File: /mozilla/src/cvs/mozilla/dist/bin/components/xpti.dat
+++ JavaScript debugging hooks installed.
nsNativeComponentLoader: autoregistering begins.
nsNativeComponentLoader: autoregistering succeeded
nNCL: registering deferred (0)
nsNativeComponentLoader: autoregistering begins.
nsNativeComponentLoader: autoregistering succeeded
nNCL: registering deferred (0)
nsNativeComponentLoader: autoregistering begins.
nsNativeComponentLoader: autoregistering succeeded
nNCL: registering deferred (0)
WARNING: dependent window created without a parent, file nsWindowCreator.cpp,
line 128
GFX: dpi=101 t2p=0.0714286 p2t=14 depth=16
we don't handle eBorderStyle_close yet... please fix me
WEBSHELL+ = 1
Note: verifyreflow is disabled
Note: styleverifytree is disabled
./mozilla-bin: error in loading shared libraries:
/mozilla/src/cvs/mozilla/dist/bin/components/libgfx_gtk.so: undefined symbol:
GetContent__C8nsIFramePP10nsIContent
mw@mw:/mozilla/src/cvs/mozilla/dist/bin$

Trying TestGtkEmbed:

mw@mw:/mozilla/src/cvs/mozilla/dist/bin$ ./TestGtkEmbed
new_gtk_browser
        menu bar
        tool bar
        location bar
        status bar
Type Manifest File: /mozilla/src/cvs/mozilla/dist/bin/components/xpti.dat
+++ JavaScript debugging hooks installed.
nsNativeComponentLoader: autoregistering begins.
nsNativeComponentLoader: autoregistering succeeded
nNCL: registering deferred (0)
GFX: dpi=101 t2p=0.0714286 p2t=14 depth=16
WEBSHELL+ = 1
loading url www.dr.dk
CSS Error (file:///home/mw/.TestGtkEmbed/TestGtkEmbed/chrome/userContent.css
:24.0): Unexpected end of file while searching for selector.  Unexpected end of
file while searching for ',
' or '{'.  Ruleset ignored due to bad selector.
CSS Error (file:///home/mw/.TestGtkEmbed/TestGtkEmbed/chrome/userContent.css
:24.0): Unexpected end of file while searching for closing } of invalid rule set.
open_uri_cb http://www.dr.dk/
load_started_cb
location_changed_cb
Note: verifyreflow is disabled
Note: styleverifytree is disabled
title_changed_cb
progress_change_cb cur 53713 max -1
progress_change_cb cur 55081 max -1
progress_change_cb cur 56449 max -1
progress_change_cb cur 57817 max -1
progress_change_cb cur 60521 max -1
progress_change_cb cur 61889 max -1
progress_change_cb cur 63257 max -1
progress_change_cb cur 64625 max -1
progress_change_cb cur 65993 max -1
progress_change_cb cur 67329 max -1
progress_change_cb cur 68697 max -1
progress_change_cb cur 70065 max -1
progress_change_cb cur 71433 max -1
progress_change_cb cur 72801 max -1
progress_change_cb cur 74169 max -1
progress_change_cb cur 75505 max -1
progress_change_cb cur 76873 max -1
progress_change_cb cur 78241 max -1
net_state_change_cb 65552
CSS Error (http://www.dr.dk/nav/nytop2/FrontPage.css :60.2): Selector expected.
 Ruleset ignored due to bad selector.
CSS Error (http://www.dr.dk/nav/nytop2/FrontPage.css :160.12): Unknown property
'font-color'.  Declaration dropped.
CSS Error (http://www.dr.dk/nav/nytop2/FrontPage.css :163.12): Error in parsing
value for property 'font'.  Declaration dropped.
CSS Error (http://www.dr.dk/nav/nytop2/FrontPage.css :174.12): Error in parsing
value for property 'font'.  Declaration dropped.
CSS Error (http://www.dr.dk/nav/nytop2/FrontPage.css :187.12): Error in parsing
value for property 'font'.  Declaration dropped.
CSS Error (http://www.dr.dk/nav/nytop2/FrontPage.css :290.13): Expected end of
value for property but found 'padding-left'.  Error in parsing value for
property 'padding'.  Declaration
 dropped.
Note: frameverifytree is disabled
./TestGtkEmbed: error in loading shared libraries:
/mozilla/src/cvs/mozilla/dist/bin/components/libeditor.so: undefined symbol:
GetViewExternal__C8nsIFrameP14nsIPresContext
mw@mw:/mozilla/src/cvs/mozilla/dist/bin$

I'm on a Debian Potato platform using gcc 2.95.2. There are no problems with the
1.4 release source.

This might be side effects from checkins related to bug #190735.

Build was from a completely clean checkout - twice.

Updated

15 years ago
Severity: normal → critical
Keywords: crash
I've had this problem too.  I worked around it by adding:
       export LD_PRELOAD="$MOZ_DIST_BIN/components/libgklayout.so"
just before the binary is executed in mozilla/dist/bin/run-mozilla.sh

Comment 2

15 years ago
I can't confirm this on Linux with gcc 2.95.3 and odays cvs (20030807)
compiled mozilla.

My "about:buildconfig" shows:

about:buildconfig

Build platform
target
i686-pc-linux-gnu

Build tools
Compiler 	Version 	Compiler flags
gcc 	gcc version 2.95.3 20010315 (release) 	-Wall -W -Wno-unused -Wpointer-arith
-Wcast-align -pedantic -Wno-long-long -I/opt/src/mozilla/dist/public/ldap
-pthread -pipe
g++ 	gcc version 2.95.3 20010315 (release) 	-fno-rtti -fno-exceptions -Wall
-Wconversion -Wpointer-arith -Wcast-align -Woverloaded-virtual -Wsynth
-Wno-ctor-dtor-privacy -pedantic -Wno-long-long
-I/opt/src/mozilla/dist/public/ldap -I/usr/local/include -pthread -pipe
-I/opt/src/mozilla/dist/public/ldap -I/usr/X11R6/include

Configure arguments
--with-gtk --disable-nls --disable-static --disable-tests --disable-logging
--enable-optimize --enable-ldap-experimental --enable-crypto --enable-mathml
--with-extensions --with-pthreads --enable-reorder
--with-libIDL-prefix=/usr/local --with-system-zlib=/usr/local
--with-system-png=/usr/local --with-system-jpeg=/usr/local
--with-system-mng=/usr/local --enable-extensions --enable-xft --enable-calendar
--enable-default-toolkit=gtk2 --disable-debug --enable-strip --enable-strip-libs 

*** This bug has been marked as a duplicate of 213839 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.