textarea problems; no caret, browser freeze

RESOLVED DUPLICATE of bug 175896

Status

()

--
critical
RESOLVED DUPLICATE of bug 175896
15 years ago
15 years ago

People

(Reporter: waider, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030806
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030806

In the above URL, the textarea at the end of the page has no caret in it. More
seriously, if large amounts of text are entered, after a certain point the text
is no longer displayed; finally, once you've gotten to this point, if you select
and delete some text, the browser will freeze. The freeze doesn't necessarily
happen immediately; you may have to select and delete a few times, or select and
try to enter more text.

Reproducible: Always

Steps to Reproduce:
1. load page
2. focus on textarea at end
3. type lots
4. after text stops appearing, select some text and press "backspace"
5. repeat 4 until browser freezes

Actual Results:  
frozen browser. kill to get out.

Expected Results:  
not frozen.

The above URL may expire. I'll upload the text of the page as an attachment.
(Reporter)

Comment 1

15 years ago
Created attachment 129363 [details]
Tarball of testcase website

Tarball of the page and included files, in case it expires before someone gets
a chance to look at the bug.

Comment 2

15 years ago

*** This bug has been marked as a duplicate of 175896 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.