Browser crashes upon entering page and trying to navigate to "Licensing Info".. Once I made it to licensing info and it crashed then.

VERIFIED DUPLICATE of bug 200511

Status

()

defect
--
critical
VERIFIED DUPLICATE of bug 200511
16 years ago
16 years ago

People

(Reporter: zorin, Assigned: bugzilla)

Tracking

({crash})

Firefox Tracking Flags

(Not tracked)

Details

()

Reporter

Description

16 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.5a) Gecko/20030728 Mozilla Firebird/0.6.1
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.5a) Gecko/20030728 Mozilla Firebird/0.6.1

Here is a MacOSX Crash Log:

Date/Time:  2003-08-07 14:10:02 -0400
OS Version: 10.2.6 (Build 6L60)
Host:       nala

Command:    MozillaFirebird-bin
PID:        630

Exception:  EXC_BAD_ACCESS (0x0001)
Codes:      KERN_PROTECTION_FAILURE (0x0002) at 0x00000000

Thread 0 Crashed:
 #0   0x91a7f470 in GetQDGlobalsBlack
 #1   0x03909d70 in 0x3909d70
 #2   0x03976ea8 in 0x3976ea8
 #3   0x03976964 in 0x3976964
 #4   0x039088d4 in 0x39088d4
 #5   0x03987bbc in 0x3987bbc
 #6   0x03966848 in 0x3966848
 #7   0x0396d13c in 0x396d13c
 #8   0x0397662c in 0x397662c
 #9   0x03999aec in 0x3999aec
 #10  0x038ff070 in 0x38ff070
 #11  0x038fe9b0 in 0x38fe9b0
 #12  0x029e0508 in
ns4xPluginStreamListener::OnDataAvailable(nsIPluginStreamInfo*, nsIInputStream*,
unsigned)
 #13  0x029e555c in nsPluginStreamListenerPeer::OnDataAvailable(nsIRequest*,
nsISupports*, nsIInputStream*, unsigned, unsigned)
 #14  0x00830174 in nsStreamListenerTee::OnDataAvailable(nsIRequest*,
nsISupports*, nsIInputStream*, unsigned, unsigned)
 #15  0x00894598 in nsHttpChannel::OnDataAvailable(nsIRequest*, nsISupports*,
nsIInputStream*, unsigned, unsigned)
 #16  0x00818384 in nsInputStreamPump::OnStateTransfer()
 #17  0x00818134 in nsInputStreamPump::OnInputStreamReady(nsIAsyncInputStream*)
 #18  0x002f9484 in nsInputStreamReadyEvent::EventHandler(PLEvent*)
 #19  0x002ac1ec in PL_HandleEvent
 #20  0x002ac110 in PL_ProcessPendingEvents
 #21  0x002ac5f4 in _md_EventReceiverProc
 #22  0x969a2c54 in DispatchEventToHandlers
 #23  0x969a2fbc in SendEventToEventTargetInternal
 #24  0x969a63d0 in SendEventToEventTargetWithOptions
 #25  0x969b2940 in ToolboxEventDispatcherHandler(OpaqueEventHandlerCallRef*,
OpaqueEventRef*, void*)
 #26  0x969a2d0c in DispatchEventToHandlers
 #27  0x969a2fbc in SendEventToEventTargetInternal
 #28  0x969b5494 in SendEventToEventTarget
 #29  0x969b7258 in ToolboxEventDispatcher(OpaqueEventRef*)
 #30  0x969c8740 in CallEventDispatchHook
 #31  0x969b3c90 in TryEventDispatcher
 #32  0x969a4570 in GetOrPeekEvent
 #33  0x969a4330 in GetNextEventMatchingMask
 #34  0x969a8054 in WNEInternal
 #35  0x969adf0c in WaitNextEvent
 #36  0x00abc980 in nsMacMessagePump::GetEvent(EventRecord&)
 #37  0x00abc85c in nsMacMessagePump::DoMessagePump()
 #38  0x00ab0310 in nsAppShell::Run()
 #39  0x00005a10 in main1(int, char**, nsISupports*, nsXREAppData const&)
 #40  0x000060c0 in xre_main(int, char**, nsXREAppData const&)
 #41  0x00002b44 in main
 #42  0x0000283c in _start
 #43  0x000026bc in start

Thread 1:
 #0   0x9002578c in select
 #1   0x001be9e4 in poll
 #2   0x001bb1d8 in _pr_poll_with_poll
 #3   0x0082fb40 in nsSocketTransportService::Run()
 #4   0x002aeafc in nsThread::Main(void*)
 #5   0x001bc640 in _pt_root
 #6   0x90020d28 in _pthread_body

Thread 2:
 #0   0x9003ea88 in semaphore_wait_signal_trap
 #1   0x9003e8a4 in _pthread_cond_wait
 #2   0x001b7750 in PR_WaitCondVar
 #3   0x00838a84 in nsDNSService::DequeuePendingQ()
 #4   0x008384b8 in nsDNSService::Run()
 #5   0x002aeafc in nsThread::Main(void*)
 #6   0x001bc640 in _pt_root
 #7   0x90020d28 in _pthread_body

Thread 3:
 #0   0x90042668 in semaphore_timedwait_signal_trap
 #1   0x9003e894 in _pthread_cond_wait
 #2   0x001b7514 in pt_TimedWait
 #3   0x001b7764 in PR_WaitCondVar
 #4   0x002b2548 in TimerThread::Run()
 #5   0x002aeafc in nsThread::Main(void*)
 #6   0x001bc640 in _pt_root
 #7   0x90020d28 in _pthread_body

Thread 4:
 #0   0x9003ea88 in semaphore_wait_signal_trap
 #1   0x9003e8a4 in _pthread_cond_wait
 #2   0x001b7750 in PR_WaitCondVar
 #3   0x002afc24 in nsThreadPool::GetRequest(nsIThread*)
 #4   0x002b04f0 in nsThreadPoolRunnable::Run()
 #5   0x002aeafc in nsThread::Main(void*)
 #6   0x001bc640 in _pt_root
 #7   0x90020d28 in _pthread_body

PPC Thread State:
  srr0: 0x91a7f470 srr1: 0x0200f030                vrsave: 0x00000000
   xer: 0x00000000   lr: 0x03909d70  ctr: 0x91a7f438   mq: 0x00000000
    r0: 0xffff0000   r1: 0xbfffea70   r2: 0x91a91910   r3: 0x00000000
    r4: 0x0005f21c   r5: 0x00000020   r6: 0x00000013   r7: 0x91a7f440
    r8: 0x0000ffff   r9: 0x0000ffff  r10: 0xffff0000  r11: 0xffffffff
   r12: 0xffffffff  r13: 0x00000000  r14: 0xbffffd90  r15: 0xbffffe9c
   r16: 0x00000002  r17: 0x000153dc  r18: 0x00000000  r19: 0x00000000
   r20: 0x00000002  r21: 0x00000000  r22: 0x00000000  r23: 0x03625e80
   r24: 0x035f4960  r25: 0x0373c628  r26: 0x03b8f020  r27: 0x035f4960
   r28: 0x00000233  r29: 0x037fa994  r30: 0x037fa994  r31: 0x037fafb8



Reproducible: Always

Steps to Reproduce:
1. Open browser
2. Visit idsoftware.com
3. Crashes shortly after load

Actual Results:  
Crashes.

Expected Results:  
Should not crash on this page.

Note that turning off Java and Javascript did not prevent the crash. The
Talkback posted is with Java and Javascript on, though.

Comment 1

16 years ago
reporter, what version of the flash plugin do you have installed?

Also, do you see this crash in current Mozilla (seamonkey) builds?

(WFM Firebird OS X 08-05)
Keywords: crash
Reporter

Comment 2

16 years ago
Yes, crashes on Seamonkey 20030803, latest trunk as of just now.

Flash plugin:  File name: Shockwave Flash NP-PPC
                   Shockwave Flash 6.0 r29

Perhaps I should try upgrading? I never actually downloaded and installed
flash; I believe it came with the system.

-John
Reporter

Comment 3

16 years ago
It was indeed the flash plugin; I upgraded it and now the problem is gone.

This can probably be resolved as invalid.

-Z

Comment 4

16 years ago

*** This bug has been marked as a duplicate of 200511 ***
Status: UNCONFIRMED → RESOLVED
Closed: 16 years ago
Resolution: --- → DUPLICATE
Verified using Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5b)
Gecko/20030817 Mozilla Firebird/0.6.1+
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.