ability to ignore fixed width and fixed height, tables percent too.

VERIFIED WONTFIX

Status

()

Firefox
General
--
enhancement
VERIFIED WONTFIX
14 years ago
11 years ago

People

(Reporter: Aaron Peterson, Assigned: Aaron Peterson)

Tracking

(Depends on: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Assignee)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5b) Gecko/20030726 Mozilla Firebird/0.6.1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5b) Gecko/20030726 Mozilla Firebird/0.6.1

I can't read the tiny fonts on the web pages... so I have to zoom in.

It would be nice to have an a set of options with regards to this issue.
(control plus and control minus behavior)
"ignore hard coded table sizes while enlarging text"
"crop text and follow table size" (what happens now)
"zoom the whole page" (ala opera)
"dragable cell boundaries" (ala composer... oh wait.. no composer in Firebird...)

<off topic>
The composer is the MOST interesting part of Mozilla, and is the most likely
location of innovation.   I am thinking of wikis that one can just hit a button
on the browser, and start editing in WYSIWUG...  and that is similar to the
draggable cell boundaries..


actually... it would be nice to have a zoom in feature that is like opera...

Reproducible: Always

Steps to Reproduce:
1.hit control + on a webpage with hard coded sizes
2.
3.

Actual Results:  
cant read half the text  (text close to the margins was cropped)

Expected Results:  
at least make it scrollable so that all the text is usable...

other options in details.

Comment 1

14 years ago
WFM 20030807 PC/WinXP

Comment 2

14 years ago
This is intended behaviour on this website.
-> INVALID
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
(Assignee)

Comment 3

14 years ago
Umm.. 
I doubt that a person wishes to have an unreadable website.

I don't write clearly when I've got zillions of ideas that I want to just write
down, so I'll try to clean it up a bit.

Go ahead an mark this a feature request if you really want to...

There needs to be a way of scrolling inside the table cell that OVERRIDES the
"wishes"/lack of foresight of the content displayer. changing text size is
_also_ not intended behavior on the website...  but it needs to be done and you
have a half implemented feature.

I'm not talking about scroll bars (though that could be nice as an option) I'm
talking about highlighting text and moving the cursor...

I'm also including a wish for optional Opera style zooming in where everything
is scaled. (though I don't want it most of the time)

I would like an option that makes
pages like the zope book (www.zope.org) text forced within the margins of the
screen.

This is an accessability issue, primarily, witch is why I say it is a bug
instead of a feature request
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---

Updated

14 years ago
QA Contact: asa

Comment 4

14 years ago
>Umm.. 
>I doubt that a person wishes to have an unreadable website.

The person who wrote that website, intended it to be this way. This is not a bug
in Firebird. Firebird only renders what it is told to render. So this is INVALID.

>There needs to be a way of scrolling inside the table cell that OVERRIDES the
>"wishes"/lack of foresight of the content displayer. changing text size is
>_also_ not intended behavior on the website...  but it needs to be done and you
>have a half implemented feature.

You can mark the text and scroll down while marking it. That's the only way I
know to get to read the text on that page.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago14 years ago
QA Contact: bugzilla
Resolution: --- → INVALID
(Assignee)

Comment 5

14 years ago
Switched it to a product enhancement request

I guess this would be a gecko thing... and not an xul thing...

but a potential fix would be disabling the fixed size aspects of the html/css/..

So... If I make a browser css sheet that outclasses all other css info, I should
be able to tell the table cells to never be of a fixed size...


I'm looking into fixing this... and I'm looking here. Nobody is forcing anybody
to help me, (but I guess this will pop up under an over worked person's nose and
irritate them)

people who look for extensions to build for firebird browse bugzilla... marking
things invalid might keep people from seeing needed abilities.
Severity: normal → enhancement
Status: RESOLVED → UNCONFIRMED
OS: Linux → All
Resolution: INVALID → ---
(Assignee)

Comment 6

14 years ago
I'm still looking for the magic css sauce, and found this:
(so only opera is in line with this guideline)
http://www.w3.org/TR/REC-CSS2/ui.html

18.5 Magnification

The CSS working group considers that the magnification of a document or portions
of a document should not be specified through style sheets. User agents may
support such magnification in different ways (e.g., larger images, louder
sounds, etc.)

When magnifying a page, UAs should preserve the relationships between positioned
elements. For example, a comic strip may be composed of images with overlaid
text elements. When magnifying this page, a user agent should keep the text
within the comic strip balloon. 

(Assignee)

Updated

14 years ago
Depends on: 208641

Comment 7

14 years ago

*** This bug has been marked as a duplicate of 4821 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago14 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 8

14 years ago
This is not a duplicate of the zoom bug. I already saw that one when I added
this.. It is similar.. but it's a differnt issue.  I've distilled it a bit more.


I need to be able to zoom in... AND have the contents still fit on the page.

The way to do this is with my own userContent.css file...
well... I looked up the css pages at w3c and thought that this:

<style>
* { width: auto; !important
   height: auto; !important
 }
</style>

would work...  (or replace * with table.. and td and th and tr...

well... I didn't see any changes in my document after reloading it (and other
test css ... and I found that bug 208641 already covered that.

I reloaded the browser and still no changes... I'm still a bit queasy about the
not symbol meaning "very" in css...

anyway the purpose of bug 208641 seems to have another aspect of this...
I asked the reporter of 208641 for a copy of his css... but I suspect that he
was manually editing it on a case by case basis rather than having a script do it.

This is also for rendering on small screens... so maybe somebody fixed this... 
I just need to find a way to implement it in the regular browser.

I did a few bugzilla searches to see if this was already mentioned... and if
this is a dupe, I don't see the one that it is a dupe of.

I know it looks bad to have lots of "bugs"... can you assign these "bugs" to
people outside of your team?  assign it to me alpeterson@wsu.edu if nobody else
wants it.


Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
Summary: control + large fonts don't expand containing table cell, cant see text → ability to ignore fixed width and fixed height, tables percent too.

Comment 9

14 years ago
You want it, you own it.
Assignee: blake → alpeterson
(Assignee)

Comment 10

14 years ago
http://texturizer.net/firebird/extensions/#editcss
appears to do some cool stuff

Comment 11

14 years ago
This is not going to be fixed in Mozilla. If you'd like to fix it with a custom
user style sheet or by building a browser extensions (possibly hosted at mozdev)
then feel free to do so but it's not happening for Mozilla.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago14 years ago
Resolution: --- → WONTFIX

Updated

14 years ago
Status: RESOLVED → VERIFIED

Updated

11 years ago
QA Contact: bugzilla → general
You need to log in before you can comment on or make changes to this bug.