Closed Bug 21549 Opened 23 years ago Closed 23 years ago

[4.xP] selecting item in context menu requires second click (left)

Categories

(SeaMonkey :: General, enhancement, P3)

x86
Linux
enhancement

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 16766

People

(Reporter: sarnold, Assigned: german)

Details

When I am using the context sensitive menus, brought up by right-clicking, I
have to release the right mouse button and click on the item I want with the
left mouse button... all this extra clicking..

It would be nice to be able to click and hold the right mouse button, find the
menu item desired, and release the right menu button, as well as allowing a
rightclick to bring up the menu, and then clicking with either mouse button on
the menu that pops up.

thanks.
Assignee: leger → german
Severity: normal → enhancement
Component: Browser-General → UE/UI
QA Contact: leger → elig
Reassigning to German as a UI/UE enhancement request.

sarnold@willamette.edu : Do you know of any applications in popular use on your
platform that already support this behavior?
Netscape Navigator does most of it, the important one, to me -- it allows for
click-hold with right mouse button, release right mouse button on desired
context item. (The standard menus allow for click-release, click on chosen
option. Mixing the two would make sense to me..)

licq, though not in "popular use", supports what I described, and maybe other
KDE-based programs do as well. (They are a bit memory hungry, so I try to avoid
them..)

Does this mean the lack of this feature is due to how the platform historically
behaves? I suppose that makes sense, but the context-menu handling of windows
(if I am recalling it correctly) isn't wrong..
Status: NEW → ASSIGNED
Target Milestone: M16
which platform are you on? I do not know of any platform that supports this
behavior.(that in itself of course is not a reason not do it). Making the menu
sticky (meaning you click and it pops up, users don't have to hold the mouse
button ) in my mind is the right behavior for this type of menu, which is more
of a secondary disclosure UI.
I want both sticky *and* non-sticky use -- (hehe, cake && eat) -- in the sense
that, to *have to* click twice on a menu item, when years of conditioning have
told me that I can click down once, select the menu item I want, and release it
works just as well, but requires less clicking.

I think it is mainly a matter of style -- some people like to click twice,
others like to click once. I am a single-click kind of person. :) I don't know
if the widgets support it, but it sure would be nice if they did -- perhaps the
code could be copied from qt2 (if its license fits well enough) since licq has
the behavior I am looking for. :)

(I think Win32 also has the behavior I am looking for, but I haven't a win32
machine to see...)

*I* would be pleased if the menus weren't sticky. I can see why people would
like them sticky. They aren't mutually exclusive -- and no switches need to be
set either. Hmm.

Perhaps the best I can suggest is try out licq for a bit, and see how the
context menus are handled there. I should try it on Win95 in the computer labs
here and see if they do what I am after with their default widgets...

Thanks! :)
Depends on: 17519
Yes; 17519 describes one of two behaviors I would like to see with the context

menus. :)



Thanks
QA Contact: elig → sairuh
spam: reassigning QA contact to self.
Dependant bug changed to 17159 from 17519 which was about selection on forms.

From "UI Bugs (01-18)" in netscape.public.mozilla.ui:
Mark Macek wrote:
* context menus should pop up on right button release, not press

Lemming wrote in reply to Mark Macek:
I disagree. It should turn up on mousedown so people used to using Mac menus 
(click and hold) can use it. I am included in this group, altough I normally use 
a PC.

Dean Tessman wrote in reply to Lemming:
The "standard" that Microsoft has introduced for Windows is when the right 
button is released.  I think that this is mostly that they can allow different 
actions for click-and-drag (eg. drag a file in Explorer using the right mouse 
button instead of the left and then release - you get a popup menu with possible 
actions).
When did Macs get two button mice? AFAIK a Mac user can't be used to
right-clicking - it's not possible on a Mac. Or are you saying that the
PC platform should be altered for people who are used to Macs, but now
use PC's?

Jerry Baker wrote in reply to Lemming:
When did Macs get two button mice? AFAIK a Mac user can't be used to
right-clicking - it's not possible on a Mac. Or are you saying that the
PC platform should be altered for people who are used to Macs, but now
use PC's? (More, less relevant replies to this message in above thread)

Lemming wrote in reply to Jerry Baker:
It is actually consistant with the normal windows menus, they appear onmousedown 
not up. But that was not my point.

When you use normal menus on a mac you click to open the menu, then without 
releasing the mouse button drag
down the menu and release to select the item. It is possible to do this with 
normal windows menus and the Mozilla
menus. 

But it is not possible with the context menu, you must first release the button. 
Whether this is the right button or left
button doesn't matter, fact is you have to release it, which just does not fit 
with how people like me are used to
working. I don't want to have to think 'what computer am I using?' every time I 
click, infact I normally click and hold the
right mouse button/right side of the mouse button until a menu appears - the 
same method works on both systems. 

And it is not just me, a large number of people use a Mac regularly enough to 
get used to clicking and holding the
menus, even when their main machine is a PC. 

Jerry Baker replied:
Clicking and holding also works on 4.x Windows context menus.
Depends on: 17159
No longer depends on: 17519
The core of this bug, distinct from bug 17159, "[4.xP] right click doesn't work 
within context menus", is that it is necessary to click a second time to
activate an item on a context menu; it is not possible to press the right mouse 
button to bring up the menu, hold it down, move the cursor to the desired item, 
and let up the button to chose the item. That works on NN 4.7 on NT, and on 
Linux, which makes this a [4.xP] bug too. 

As noted, this is more important to Mac users, who ctrl-(only-mouse-button)-
click, than to anyone else, but there is no reason why this can't work the
same way for ctrl-click and right-click, otherwise being completely XP.

The click-and-hold behaviour can coexist with the bug 17159 behaviour with
no conflicts; they do on 4.x.

Tested with: NN 4.7 on Windows NT 4.0sp3; also tested by sarnold@willamette.edu
on Linux.

Changing summary from "context menus require left-click" to 
"[4.xP] selecting item in context menu requires second click (left)"
to show what is distinctive about this bug. This doesn't look like an 
enhancement anymore, it looks like an "XP Toolkit/Widgets: Menus" bug.
Summary: context menus require left-click → [4.xP] selecting item in context menu requires second click [4.xP] selecting item in context menu requires second click [4.xP] selecting item in context menu requires second click [4.xP] selecting item in context menu requires second click [4.xP] selectin
Oops, fixing Summary. Fun with cut-n-paste gone awry. Sorry about the spam.
Summary: [4.xP] selecting item in context menu requires second click [4.xP] selecting item in context menu requires second click [4.xP] selecting item in context menu requires second click [4.xP] selecting item in context menu requires second click [4.xP] selectin → [4.xP] selecting item in context menu requires second click (left)
I'd like an option to show the context menu on button-release. This is mainly
because I want drag-and-drop on right button (like Windows and OS/2 have it).
Well, windows manages to have drag-and-drop on the right mouse button in
addition to the left mouse button, and it is still able to show the context
menu
before button-release. I have trouble describing exactly how it works,
but it
seems to be very intuitive, however it does work -- perhaps it waits
to see if
the mouse moves in the first five milliseconds after button-down,
but that is
just a guess.

Do try playing with the context menus of navigator under windows;
(under 
linux, navigator does my preferred click-once style, but it does not
allow the 'click-twice' style that others enjoy and that mozilla under linux
uses.) Under windows, it supports both styles, in a manner that I think many
people will intuitively grasp.

Thanks
Ok, sorry I didn't get to this earlier ... this is a dup.

This bug is asking for two things:
(1) [4.xP] right click doesn't work within context menus -- dup of bug 17159
(2) [4.xP] Context menus can't be used with a single drag -- dup of bug 16766.

So, since sidr@albedo.net says `The core of this bug, distinct from bug 17159 
... is that it is not possible to press the right mouse button to bring up the 
menu, hold it down, move the cursor to the desired item, and let up the button 
to chose the item', I have great pleasure in announcing that ...

*** This bug has been marked as a duplicate of 16766 ***
Status: ASSIGNED → RESOLVED
Closed: 23 years ago
No longer depends on: 17159
Resolution: --- → DUPLICATE
verifying.
Status: RESOLVED → VERIFIED
Moving all UE/UI bugs to new component: User Interface: Design Feedback
UE/UI component will be deleted.
Component: UE/UI → User Interface: Design Feedback
Component: User Interface Design → Browser-General
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.