When using Tabed browsing, the status isn't updated with the current tab status

VERIFIED DUPLICATE of bug 104532

Status

SeaMonkey
Tabbed Browser
VERIFIED DUPLICATE of bug 104532
15 years ago
10 years ago

People

(Reporter: Luis Miguel Lagoa Baptista Ferro, Assigned: jag (Peter Annema))

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030624
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030624

If one opens several windows and one of them has a "irritating" javascript
status scroller, then, that scroller will be always on the status even if one
changes or opens new tabs.

The behavior i would expect would be to the status bar be updated with the
current tab status bar only and only if one changes to the "scroller" tab, then
the status scroller would be updated.

For performance, would also be usefull that if the "actions" of javascript are
too repeated but aren't the current tab, to be "squelshed" (processor starved a
bit), to allow better responsivity from the current tab operations [i've no idea
if this is possible, desireable, doable or even if isn't implemented already].

Reproducible: Always

Steps to Reproduce:
1. Open page with a status scroller
2. open a new tab
3. open page without a status scroller
4. swap from one to the other tab

Actual Results:  
The scroller will take over the status bar.

Expected Results:  
The scroller should only appear in the status bar when the tab with the scroller
is the current one...

Comment 1

15 years ago
This is a dup of another bug.  Someone'll find it, because I haven't yet.
->tabbed browser
Assignee: general → jaggernaut
Component: Browser-General → Tabbed Browser
QA Contact: general → pmac
Whiteboard: DUPEME

Comment 2

15 years ago

*** This bug has been marked as a duplicate of 104532 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 3

15 years ago
v dupe
Status: RESOLVED → VERIFIED
Whiteboard: DUPEME
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.