Closed Bug 215593 Opened 17 years ago Closed 17 years ago

general.startup.mail and general.startup.browser rules not followed with RPM versions of mozilla

Categories

(Core Graveyard :: X-remote, defect)

x86
Linux
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 58523

People

(Reporter: audard, Assigned: blizzard)

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030701
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030701

With mozilla 1.4 obtained from RPMs (for RH8) and installed on RedHat 9,
the following preferences are not respected:

user_pref("general.startup.browser", false);
user_pref("general.startup.mail", true);

mozilla always starts with a browser. The Mail window never appears (except if
manually called, e.g., CTRL+2 or "Window" -> "Mail & Newsgroup") 

NB: This is reproducible with the official RedHat9 released mozilla 1.2.1.
On the other hand, the *.tar.gz versions do respect the preferences and only
start with a Mail window.

Reproducible: Always

Steps to Reproduce:
1.launch mozilla selecting only Mail in the Appearance/Prefs
2.
3.

Actual Results:  
A browser always appears. The Mail window never appears by itself. It must be
generated (eg CTRL+2, etc).

Expected Results:  
Launch only a Mail window and not a browser.

Theme: Blue, but Modern/Classic do the same.
.
Assignee: bugs → blizzard
Component: Preferences → X-remote
QA Contact: sairuh → blizzard
this will only happen when you already have Mozilla open.  please make sure
Mozilla is not running when you start it.

% ps -C mozilla-bin
I disagree to the additional comment of Andrew Schulz. It occurs even if
no mozilla is running (I checked with ps -fe |grep mozilla, and with ps -C
mozilla-bin).
ahh.. now I understand, although I'm not sure the current problem would have
existed with 1.2.1

the startup script (/usr/bin/mozilla) passes "-UILocale en-US" (or whatever
other locale) as a commandline parameter (almost always).  That triggers bug 58523.

If you want the behavior you've described, you'll need to edit the script to
remove that bit, or just do "mozilla -mail", which should work fine.

marking dupe of "-P, -nosplash... switches unable to launch anything other than
the browser (mail does not open on startup)"

*** This bug has been marked as a duplicate of 58523 ***
Status: UNCONFIRMED → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE
Agreed. I removed the line:
[ -f $MOZILLA_FIVE_HOME/chrome/$MOZLOCALE.jar ] && MOZARGS="-UILocale $MOZLOCALE"

and it worked correctly (except maybe that the password for my POP account
was not automatically requested).

Sorry that I did not find the previous bug.

Marc
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.