Minimized attributes not correctly mapped to DOM

VERIFIED DUPLICATE of bug 108480

Status

()

Core
DOM: Core & HTML
VERIFIED DUPLICATE of bug 108480
15 years ago
7 years ago

People

(Reporter: Erik Arvidsson, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
Minimized attributes like readonly, disabled and more returns incorrect value
for getAttribute when there is no attribute (or the DOM property is false),

When inputElement.readOnly is set to false it should remove the readonly
attribute and therefore the call to getAttribute("readonly") should return ""
(http://www.w3.org/TR/2000/REC-DOM-Level-2-Core-20001113/core.html#ID-666EE0F9).
Currently it returns null
(Reporter)

Comment 1

15 years ago
Created attachment 129541 [details]
Tests getAttribute and more for readonly inputs

Note how it produces null for getAttribute
See bug 120681.

*** This bug has been marked as a duplicate of 108480 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Updated

10 years ago
Component: DOM: Core → DOM: Core & HTML
QA Contact: ian → general

Updated

7 years ago
Assignee: general → nobody
Status: RESOLVED → VERIFIED
OS: Windows XP → All
Hardware: x86 → All
You need to log in before you can comment on or make changes to this bug.